[DMS-456] startup.bat does not echo a localized 'y' as part of permissions setting Created: 02/Apr/09  Updated: 26/Aug/09  Resolved: 25/May/09

Status: Done
Project: dm Server
Component/s: None
Affects Version/s: 2.0.0.M1
Fix Version/s: Sprint 5, 2.0.0.M3, 2.0.0.RELEASE

Type: Defect Priority: Major
Reporter: Robert Beeger Assignee: Unassigned
Resolution: Complete Votes: 2
Labels: None
Σ Remaining Estimate: 0h Remaining Estimate: Not Specified
Σ Time Spent: 21h 11m Time Spent: Not Specified
Σ Original Estimate: 6h Original Estimate: Not Specified
Environment:

German localized Windows XP


Sub-Tasks:
Key
Summary
Type
Status
Assignee
DMS-515 Write VB Script Sub-task Done Chris Frost [X]  
DMS-516 Integrate script into windows startup Sub-task Done Chris Frost [X]  
DMS-517 Unify windows and UNIX behavior Sub-task Done Ben Hale (c)  
Story Points: 3
First Response Date:

 Description   

Spring DM Server 2 M1 does not work on a German Windows XP. Running startup.bat only results in an error message complaining that read access to jmxremote.password should be restricted.
Changing
echo y|cacls %CONFIG_DIR%\management\jmxremote.* /P %USERNAME%:F > nul
to
echo j|cacls %CONFIG_DIR%\management\jmxremote.* /P %USERNAME%:F > nul
fixes the problem

Note the "j" for "Ja" instead of "y" for "Yes".



 Comments   
Comment by Joris Kuipers [X] (Inactive) [ 03/Apr/09 ]

Same issue exists on Dutch WinXP.

BTW, in an actual production environment the server would run as a Windows service as either a dedicated user or as the Local System user and would in all likelihood not use the provided script. Maybe we should only document the ACL requirements for JMX (linking to http://java.sun.com/javase/6/docs/technotes/guides/management/security-windows.html) instead of trying to fix this in the startup script?

Comment by Julien Dubois [ 05/Apr/09 ]

Same problem with Windows Vista in French.

Comment by Sebastian Lorenz [ 06/Apr/09 ]

There seems to be another problem with this line:

echo y|cacls %CONFIG_DIR%\management\jmxremote.* /P %USERNAME%:F > nul

If you replace 'y' by the localized first character of 'yes' then the cacls command runs without problems. But you could still get the same error message. Because:

1. My user name is sebastian. My notebook has the name NB7 in a domain named BUERO.
2. If I install dm server then the jmxremote.* files always have BUERO/sebastian as the 'current owner of this item'.
3. If I remove all permission entries on the jmxremote.* files and run startup.bat then the above line in the startup file gives NB7/sebastian full access to the jmxremote files. Since NB7/sebastian and BUERO/sebastian is not same this results in the same error message.

If I manually grant full access to the 'current owner ' of the jmxremote.* files BUERO/sebastian and remove the line 'echo y|cacls ...' from the startup script, it works.

Comment by Flavio Donzé [ 26/Aug/09 ]

Here it says that this issue is resolved in version 2.0.0.M3.
I'm using 2.0.0.M4 and get the same error message on startup.

Generated at Fri Nov 24 00:04:30 UTC 2017 using JIRA 6.1.4#6159-sha1:44eaedef2e4a625c6c7183698b2468d4719c20dc.