Spring Tool Suite
  1. Spring Tool Suite
  2. STS-853

As a user, I would like to use the Atlassian Eclipse Connector

    Details

    • Type: New Feature New Feature
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.3.M2
    • Component/s: None
    • Labels:

      Activity

      Hide
      Robert Kasanicky added a comment -

      The 2.0 release of Atlassian Jira Connector advertises to fix bugs that cause the old Jira Connector to not work with Jira Studio (which affects me significantly). I expected updating would be an easy 'remove-old install-new' exercise but looks like that's not the case with STS.

      Show
      Robert Kasanicky added a comment - The 2.0 release of Atlassian Jira Connector advertises to fix bugs that cause the old Jira Connector to not work with Jira Studio (which affects me significantly). I expected updating would be an easy 'remove-old install-new' exercise but looks like that's not the case with STS.
      Hide
      Steffen Pingel added a comment -

      That is correct, STS currently depends on the Mylyn JIRA Connector and can not be installed together with the Atlassian JIRA connector. We are looking into porting STS to the Atlassian JIRA Connector.

      Show
      Steffen Pingel added a comment - That is correct, STS currently depends on the Mylyn JIRA Connector and can not be installed together with the Atlassian JIRA connector. We are looking into porting STS to the Atlassian JIRA Connector.
      Hide
      Robert Kasanicky added a comment -

      Is there any good reason why STS mandates particular Mylyn connectors? I don't see why it shouldn't be possible to install/uninstall whatever connectors users prefer. I think it's good to have popular connectors installed by default but it's bad to be locked in with specific choice - maybe this should be considered a STS bug?

      Show
      Robert Kasanicky added a comment - Is there any good reason why STS mandates particular Mylyn connectors? I don't see why it shouldn't be possible to install/uninstall whatever connectors users prefer. I think it's good to have popular connectors installed by default but it's bad to be locked in with specific choice - maybe this should be considered a STS bug?
      Hide
      Steffen Pingel added a comment -

      STS leverages the JIRA connector for improved bug reporting and other functionality and therefore requires a specific version of the JIRA connector.

      The compatibility issue has been addressed and the next version and nightly build will include the Atlassian JIRA connector which supports JIRA Studio and recent JIRA versions.

      Show
      Steffen Pingel added a comment - STS leverages the JIRA connector for improved bug reporting and other functionality and therefore requires a specific version of the JIRA connector. The compatibility issue has been addressed and the next version and nightly build will include the Atlassian JIRA connector which supports JIRA Studio and recent JIRA versions.

        People

        • Assignee:
          Unassigned
          Reporter:
          Steffen Pingel
        • Votes:
          2 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:
            First Response Date: