Spring Tool Suite
  1. Spring Tool Suite
  2. STS-796

[grails] Grails run command and dependency calculation requires JDK

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 2.6.0.M1
    • Component/s: GRAILS
    • Labels:
      None

      Description

      It appears that the run Grails command and dependency calculation require a JDK to be the default Java Runtime of the Eclipse workspace. A JRE is not sufficient and will only result in an emtpy console window.

      We should print or pop up a warning in the case somebody uses a JRE.

        Activity

        adam bennett added a comment -

        Thanks for making this ticket. I was having the same issue, and changing the workspace's JRE from my installed JRE to the JDK worked. Thanks!

        Kris De Volder (c) added a comment -

        Looks like we may have a chance to still get this fix into 2.5.2...

        Kris De Volder (c) added a comment -

        Though I've recently had a user that suffered from this issue (so the issue is probably still a real issue), I cannot seem to reproduce it on my machine.

        After having "downgraded" my JDK to a JRE I am not getting the described behavior of "an empty console" window.

        Kris De Volder (c) added a comment -

        Though I'm not getting the "empty console window". I am getting other unpredictable and cryptic errors running some commands (like "grails war" for deploying app to TcServer or "run-app", or "compile" when installing plugins etc.

        These weird behaviors go away when I reinstall my JDK. So it seems still a good idea to have this check.

        I don't think now, it is urgent enough to put this into 2.5.2. It would seem this issue doesn't affect many users because:

        • most users would have a JDK installed
        • if no JDK is installed, the user will already get warned by maven that they need to have a JDK (but is true they might choose to ignore the warning if they aren't using maven).
        Kris De Volder (c) added a comment -

        Moving back to 2.5.3. It is too risky to put in a change now that may cause nuisance to the majority of developers to help those few that don't have JDK install.

        Kris De Volder (c) added a comment -

        I've committed a fix.


          People

          • Assignee:
            Kris De Volder (c)
            Reporter:
            Christian Dupuis
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: