Spring Tool Suite
  1. Spring Tool Suite
  2. STS-614

Empty list of "Installed Bundles and Libraries" under the Repository tab

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.2.0.RELEASE
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Ubuntu 9.04, 64-bit

      Description

      Open new workspace with java 6 and see no issues:
      STS -vm /usr/lib/jvm/java-6-sun-1.6.0.16/bin/java -data /home/rossen/dev/workspaces/deleteme

      Reopen workspace with java 5 and observe the issue:
      STS -vm /usr/lib/jvm/java-1.5.0-sun-1.5.0.19/bin/java -data /home/rossen/dev/workspaces/deleteme

      See attached screenshots.

      1. log.txt
        10 kB
        Rossen Stoyanchev (c)
      1. empty.png
        163 kB
      2. full.png
        242 kB

        Activity

        Christian Dupuis added a comment -

        Rossen, can you check your error log for any issues that might relate to that.

        Christian

        Rossen Stoyanchev (c) added a comment -

        Here is the log file with all the errors.

        Sam Brannen added a comment -

        FYI: the same result (i.e., empty list) occurs with springsource-tool-suite-2.2.1.RELEASE-e3.5.1-macosx-carbon-installer.dmg on Mac OS X Leopard using the default launch settings. The server actually launches fine: you can access the splash screen and admin console; however, deployment of a simple, standard Java EE WAR from within STS fails.

        Steffen Pingel added a comment -

        The problem is that Java 1.5 does not provide a StAX implementation which is required by dm Server:

        Caused by: javax.xml.stream.FactoryConfigurationError: Provider com.bea.xml.stream.XMLOutputFactoryBase not found
        at javax.xml.stream.FactoryFinder.newInstance(FactoryFinder.java:72)
        at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:178)
        at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:92)
        at javax.xml.stream.XMLOutputFactory.newInstance(XMLOutputFactory.java:101)
        at com.springsource.repository.codec.XMLRepositoryCodec.write(XMLRepositoryCodec.java:73)
        [...]

        As a work-around we could replace the table with a message that Java 6 is required to view the list of installed bundles. Christian, what do you suggest?

        Martin Lippert (c) added a comment -

        The dm Server tooling is now contributed to the Eclipse Virgo project, therefore I will close this issue here. If this is still an issue, please raise this again at the new project location via:

        https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Virgo
        (choosing the "tooling" component)

        Thank you very much!


          People

          • Assignee:
            Unassigned
            Reporter:
            Rossen Stoyanchev (c)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: