Details

    • Type: Sub-task Sub-task
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 2.5.1.RELEASE
    • Component/s: GRAILS
    • Labels:
      None

      Description

      Since 'grails war' just creates a WAR file other STS tools that use WAR files can be used with Grails whether it be cloud tools, deployment onto containers etc.

        Activity

        Rob Purcell added a comment -

        This would be ideal: allow Grails to deploy to the STS Tomcat instance to allow simple usage of Spring Insight.

        Matt Stine added a comment -

        I could REALLY use this for deploying Grails to dm Server....building the WAR and the dropping into the dm Server pickup directory is extremely cumbersome.

        Steve Mayzak added a comment -

        I would love to be able to use a Grails app inside STS and have Insight instrument it without having to go outside of sts.

        Graeme Rocher added a comment -

        That would work if STS just used the 'grails war' command and deployed to the configured tc Server developer edition. Could be a one click operation.

        Steve Mayzak added a comment -

        Graeme,

        I have that working now, just modified the config. What about the run-app command though? I would like to be able to run my app and have it dynamically reload my changes just like it normally does but while its running on tc Server with Insight instrumentation. I am sure I could figure this out given the time, just thought someone may have already tried.

        Kris De Volder (c) added a comment -

        I'm going to look into this in the near future. The idea would be to try and get something up and running that allows drag/drop a grails app project onto the tc-server instance in STS.

        Docent Klekot added a comment -

        This would be very usefull feature, seamless deployement to configured container in STS I really miss that while developing Grails apps

        Kris De Volder (c) added a comment -

        I've got a little bit of good news about this .

        I've got something in my workspace that more or less works. You can drag-drop to TC-server or use the "add-remove" menu on the server tab. Then it automatically builds the .war file and unzips it to deploy to the server.

        This is still highly experimental and not ready for release. For example running in debug mode doesn't work that well. Also haven't had much chance to test what happens when you are editing / changing the project while it is deployed.

        So this is not going to make it into the upcoming 2.5 release.

        After the release I'll probably put the stuff in so that it becomes available from the nightly update site. That way, people who want to have a go, can try it out and provide some feedback and bugreports.

        I'll post updates here when something is available to try.

        Kris De Volder (c) added a comment -

        Quick update:

        I've put a bit more work into this. I also got the source locators to work. So now when doing "Debug On Server" and you hit a breakpoint in your code, you actually get to see your source code .

        We'll do a bit more testing before I put this into the STS build. Currently it all lives in a separate plugin that, while it committed to the source repository, isn't picked-up by the automatic build yet.

        Andy Clement (c) added a comment -

        When this is behaving, we need to also ensure the Servers view is open in the Grails perspective.

        Kris De Volder (c) added a comment -

        I'm closing this as complete. That doesn't mean that we can't work on and improve this in the future. But it means we have something that does the basics allowing a user to drag/drop a grails app on a TcServer instance and keep the app in synch with the deployed copy as the user edits resources in their project.

        Docent Klekot added a comment -

        I have just upgraded STS to 2.5.1 and looking at this feature. It is a nice improvement, I have noticed that drag and drop and Run On server options are not available for Grails Plugin Projects. Is that by design? will this be possible in the future?
        Thanks
        Klekot

        Graeme Rocher added a comment -

        This is a limitation of Grails not STS, currently plugins cannot (as of this writing) be deployed as WAR files


          People

          • Assignee:
            Kris De Volder (c)
            Reporter:
            Graeme Rocher
          • Votes:
            8 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: