Details

    • Type: Sub-task Sub-task
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 2.3.3.M2
    • Component/s: None
    • Labels:
      None

      Description

      It should be possible to easily navigate to different artefacts in the editor. For example in a controller action:

      class BarController {
        def foo = {}
      }
      

      CMD+Clicking on foo should take you to /bar/foo.gsp and if it doesn't exist prompt whether you want to create it. The same with tag libraries if you have:

      <foo:bar />
      

      CMD+clicking on this tag should take you to the tag library that has a namespace of "foo" and a tag of "bar" such as:

      class FooTagLib {
         static namespace = "foo"
         def bar = { attrs, body -> }
      }
      

      It the tag library doesn't exist again it should prompt to create it. Another example if you have in a controller:

      class BarController {
        def foo = {
          render template:"foo"
        }
      }
      

      If you click on the templat name "foo" it should try to open grails-app/views/bar/_foo.gsp and if it doesn't exist prompt to create it. Layouts are another example. If you have in a GSP:

      <meta name="layout" content="main" />
      

      Clicking on "main" should open grails-app/views/layouts/main.gsp

      There are probably other examples of this kind of interaction

        Activity

        Graeme Rocher added a comment -

        Hmm sorry the formatting got messed up and I can't seem to correct it

        Andrew Eisenberg (c) added a comment -

        This is a duplicate of STS-974.


          People

          • Assignee:
            Andrew Eisenberg (c)
            Reporter:
            Graeme Rocher
          • Votes:
            9 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: