Spring Tool Suite
  1. Spring Tool Suite
  2. STS-3647

After installing STS on Kepler. Update site inaccessable

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.4.0.RELEASE
    • Fix Version/s: 3.5.0.M2
    • Component/s: SUPPORT
    • Labels:
      None
    • Environment:

      Windows 32 bit Eclipse Kelper (also full STS from Springsource)

      Description

      Working for Big wireless company. System behind a proxy that requires authentication. Preferences->Network Connections->Active Provider set to Manual. HTTP and HTTPS values filled in for proxy host, port, Auth (yes), User and password all populated.

      When Kepler is installed without STS, Marketpace works as expected. Install STS and going to Marketplace fails.

      Error:
      {{monospaced}}Cannot install remote marketplace locations: HTTP Proxy Authentication Required: http://marketplace.eclipse.org/catalogs/api/p

      Stack trace:
      {{monospaced}}org.eclipse.core.runtime.CoreException: HTTP Proxy Authentication Required: http://marketplace.eclipse.org/catalogs/api/p
      at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryTransport.stream(RepositoryTransport.java:180)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.epp.internal.mpc.core.util.AbstractP2TransportFactory.invokeStream(AbstractP2TransportFactory.java:35)
      at org.eclipse.epp.internal.mpc.core.util.TransportFactory$1.stream(TransportFactory.java:69)
      at org.eclipse.epp.internal.mpc.core.service.RemoteMarketplaceService.processRequest(RemoteMarketplaceService.java:131)
      at org.eclipse.epp.internal.mpc.core.service.RemoteMarketplaceService.processRequest(RemoteMarketplaceService.java:85)
      at org.eclipse.epp.internal.mpc.core.service.RemoteMarketplaceService.processRequest(RemoteMarketplaceService.java:72)
      at org.eclipse.epp.internal.mpc.core.service.DefaultCatalogService.listCatalogs(DefaultCatalogService.java:36)
      at org.eclipse.epp.internal.mpc.ui.commands.MarketplaceWizardCommand$5.run(MarketplaceWizardCommand.java:254)
      at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
      Caused by: org.eclipse.ecf.filetransfer.IncomingFileTransferException: Proxy Authentication Required
      at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientRetrieveFileTransfer.openStreams(HttpClientRetrieveFileTransfer.java:661)
      at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer.sendRetrieveRequest(AbstractRetrieveFileTransfer.java:879)
      at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer.sendRetrieveRequest(AbstractRetrieveFileTransfer.java:570)
      at org.eclipse.ecf.provider.filetransfer.retrieve.MultiProtocolRetrieveAdapter.sendRetrieveRequest(MultiProtocolRetrieveAdapter.java:106)
      at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.sendRetrieveRequest(FileReader.java:422)
      at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.read(FileReader.java:273)
      at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryTransport.stream(RepositoryTransport.java:172)
      ... 12 more

      Unstall Spring Tool Suite plugins (leaving Groovy, etc) Marketplace access is restored.

      I appears that something in the Spring STS plugins is causing proxy authentication to fail.

      I cannot use the Spring Tool Suite plugins until this issue is resolved.

        Activity

        Kris De Volder (c) added a comment -

        > As a follow-up. I went into my existing STS installation that I reported this issue with and removed the org.apache.httpcomponents..4.2..jars (they were there). Once I removed those jar files the problem was resolved as well.
        I confirmed that it worked by installing an additional plug-in

        Deleting the libs might work, however I'd caution against it. There is some code that depend on API that you have thereby removed. (I.e. the 'new spring starter project' wizard will break).
        Also I would be a bit scared of corrupting OSGI / p2 repository when you delete things just like that.

        Brendan Fagan added a comment -

        I don't think this is truly resolved.

        I'm still encountering this issue after a clean install of Kepler and an install of STS from the nightly branch. I have ensured my proxy is configured correctly and that my credentials are accessible.

        Steps to reproduce:

        • Install eclipse-standard-kepler-SR1-macosx-cocoa-x86_64.tar.gz.
        • Ensure security/proxy settings
        • Install STS via http://dist.springsource.com/snapshot/TOOLS/nightly/e4.3
        • Restart STS
        • Open Eclipse Marketplace and attempt to install the TestNG plugin (the resulting error included below)

        Spring IDE

        Version: 3.5.0.201401290809-CI-B662

        Dump from Eclipse:

        eclipse.buildId=4.3.0.M20130911-1000
        java.version=1.7.0_17
        java.vendor=Oracle Corporation
        BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
        Framework arguments: -product org.eclipse.epp.package.standard.product -keyring /Users/n51494/.eclipse_keyring -showlocation
        Command-line arguments: -os macosx -ws cocoa -arch x86_64 -product org.eclipse.epp.package.standard.product -keyring /Users/n51494/.eclipse_keyring -showlocation

        Error
        Wed Jan 29 12:11:06 EST 2014
        HTTP Proxy Authentication Required: http://beust.com/eclipse/content.xml

        org.eclipse.ecf.filetransfer.BrowseFileTransferException: Proxy auth required
        at org.eclipse.ecf.provider.filetransfer.browse.URLFileSystemBrowser.runRequest(URLFileSystemBrowser.java:129)
        at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

        Kris De Volder (c) added a comment -

        Other people who where affected by this seemed to all be on some flavor of windows and using NTLM proxy in their environment.
        You appear to be on Mac OS X. So maybe your case is different.

        If you want someone to trouble shoot and reproduce your issue on Mac OS X you will need to provide more information on how your proxy is configured, what type of proxy it is and how authentication works for that proxy.

        It would also be useful to confirm whether the problem you experience happens only in STS or also in a plain Eclipse setup / configured the exact same way.

        Kris De Volder (c) added a comment -

        Spotted another info in you report:

        > eclipse.buildId=4.3.0.M20130911-1000

        Are you sure the nightly update was installed correctly? You don't seem to be on 3.5.0 nighlty at all.
        The best thing to check would the specific bundles versions that caused the issue, as outlined above somewhere in this thread.

        Kris De Volder (c) added a comment - - edited

        Disregard comment above. I just realized my mistake. Eclipse build id has nothing to do with STS version.


          People

          • Assignee:
            Kris De Volder (c)
            Reporter:
            Chris Hamilton
          • Votes:
            3 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: