Details

    • Type: Bug Bug
    • Status: Open Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: 3.2.0.RELEASE
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Ubuntu precise 12.04;
      Window Manager awesome

      Description

      STS hangs on 100% CPU.

      Initially it is possible to import a roo-generated and "mvn eclipse"d project.

      Some coding is also possible.

      After few minutes STS isn't possible to draw its viewport on the screen, only few elements become visible during high fan usage because of cpu heat.

      I killed the processes few times now.

      Please tell me if there are perhaps some settings to reset. (This should be done by STS automatically!)

      Spring development isn't fun anymore with such a crappy IDE

      1. jstack_STS
        22 kB
        Christian Fischer

        Activity

        Hide
        Christian Fischer added a comment -

        Thanks Martin.

        I tried - without any luck.

        "Synchronizing repository ..." is occurring every time I save a file.

        I Deactivated ALL Options reading "synchronize" or "auto share" or else.

        I do also not have this team options you are talking of - only "share project".

        I think this means the projects are already not connected.

        How do i delete ALL settings data from STS and try with a fresh install?

        Show
        Christian Fischer added a comment - Thanks Martin. I tried - without any luck. "Synchronizing repository ..." is occurring every time I save a file. I Deactivated ALL Options reading "synchronize" or "auto share" or else. I do also not have this team options you are talking of - only "share project". I think this means the projects are already not connected. How do i delete ALL settings data from STS and try with a fresh install?
        Hide
        Martin Lippert (c) added a comment -

        You could just install a fresh copy this STS into a separate directory, this would give you the cleanest way. In addition to that you should choose a new and fresh workspace - and maybe re-import some of those projects to see if that happens again.

        Show
        Martin Lippert (c) added a comment - You could just install a fresh copy this STS into a separate directory, this would give you the cleanest way. In addition to that you should choose a new and fresh workspace - and maybe re-import some of those projects to see if that happens again.
        Hide
        Martin Lippert (c) added a comment -

        You could also try to update Egit to a newer version by installing the EGit features from the EGit update site. The thread dump points into the Egit direction, therefore I would definitely try this is nothing else helps.

        Show
        Martin Lippert (c) added a comment - You could also try to update Egit to a newer version by installing the EGit features from the EGit update site. The thread dump points into the Egit direction, therefore I would definitely try this is nothing else helps.
        Hide
        Martin Lippert (c) added a comment -

        And sorry for being late with the reply, so busy working on 3.3.0.M2, which was released today.

        Show
        Martin Lippert (c) added a comment - And sorry for being late with the reply, so busy working on 3.3.0.M2, which was released today.
        Hide
        Alex Boyko added a comment -

        Is this issue still a problem?

        Show
        Alex Boyko added a comment - Is this issue still a problem?

          People

          • Assignee:
            Unassigned
            Reporter:
            Christian Fischer
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              First Response Date: