Spring Tool Suite
  1. Spring Tool Suite
  2. STS-3128

Grails: cannot run a Grails 2.2.0RC4 project, error "agent library failed to init: instrument"

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.2.0.M1
    • Fix Version/s: 3.2.0.M2
    • Component/s: GRAILS
    • Labels:
      None
    • Environment:

      Win7, jdk 1.6.0_34 32bit, Grails 2.2.0RC4, STS 3.2.0M1

      Description

      Trying to run a Grails project with Run as> Grails command (run-app). I get this error:
      Error opening zip file or JAR manifest missing : null
      Error occurred during initialization of VM
      agent library failed to init: instrument

      I installed the Groovy 2.0 plugin, JDK 1.6.0_44

      This project runs form the Grails command line with the "grails run-app" command.

      It is quite difficult to understand if it is a project configuration issue or a real problem with STS. The message is cryptic. Unfortunately, that just prevents me from using STS.

        Activity

        Hide
        Fred Janon added a comment -

        On Win7, Grails 2.2.0 and STS Version: 3.2.0.M1 Build Id: 201211290906

        As indicated, in the dir:

        C:\grails-2.2.0\lib

        I created a dir:

        com.springsource.springloaded

        full path:

        C:\grails-2.2.0\lib\com.springsource.springloaded

        I copied the content of the dir:

        C:\grails-2.2.0\lib\org.springsource.springloaded

        which is another dir:

        springloaded-core

        which contains:

        • jars (dir)
        • ivy-1.1.1.xml (file)

        into the dir

        C:\grails-2.2.0\lib\com.springsource.springloaded

        I restarted STS and now I can run my project.

        Thanks

        Show
        Fred Janon added a comment - On Win7, Grails 2.2.0 and STS Version: 3.2.0.M1 Build Id: 201211290906 As indicated, in the dir: C:\grails-2.2.0\lib I created a dir: com.springsource.springloaded full path: C:\grails-2.2.0\lib\com.springsource.springloaded I copied the content of the dir: C:\grails-2.2.0\lib\org.springsource.springloaded which is another dir: springloaded-core which contains: jars (dir) ivy-1.1.1.xml (file) into the dir C:\grails-2.2.0\lib\com.springsource.springloaded I restarted STS and now I can run my project. Thanks
        Hide
        MG added a comment -

        I have the same problem with GGTS 3.5M1 and Grails 2.3.7

        Show
        MG added a comment - I have the same problem with GGTS 3.5M1 and Grails 2.3.7
        Hide
        Kris De Volder (c) added a comment -

        Yeah... the jar moved again in 2.3.7. So now you'll need 3.5.0.RC1 which is going to be released soon.

        Or you can try the nightly build: http://dist.springsource.com/snapshot/TOOLS/grails-ide/nightly

        That should work right now.

        Show
        Kris De Volder (c) added a comment - Yeah... the jar moved again in 2.3.7. So now you'll need 3.5.0.RC1 which is going to be released soon. Or you can try the nightly build: http://dist.springsource.com/snapshot/TOOLS/grails-ide/nightly That should work right now.
        Hide
        William Woodman added a comment -

        so what is happening here ("hello Kris again"). I just built myself a new PC for home.

        brand new - installed windows 8.1.
        downloaded java 64bit 7.0.51
        unpacked grails 2.3.7
        unpacked GGTS 2.3.5M2 and set the JDK, and added grails 2.3.7 as the default grails

        tried to create a new Grails project and got the same error as reported

        Error opening zip file or JAR manifest missing : null
        Error occurred during initialization of VM
        agent library failed to init: instrument

        however the same conditions on my older windows 7, and my works laptop windows 7 works ok

        both use GGTs3.5m2/grails2.3.7/java7.0.51

        i can create new projects on my old systems. but my nice clean new PC doesnt work at all

        frustrating

        Will

        Show
        William Woodman added a comment - so what is happening here ("hello Kris again"). I just built myself a new PC for home. brand new - installed windows 8.1. downloaded java 64bit 7.0.51 unpacked grails 2.3.7 unpacked GGTS 2.3.5M2 and set the JDK, and added grails 2.3.7 as the default grails tried to create a new Grails project and got the same error as reported Error opening zip file or JAR manifest missing : null Error occurred during initialization of VM agent library failed to init: instrument however the same conditions on my older windows 7, and my works laptop windows 7 works ok both use GGTs3.5m2/grails2.3.7/java7.0.51 i can create new projects on my old systems. but my nice clean new PC doesnt work at all frustrating Will
        Hide
        Kris De Volder (c) added a comment -

        Okay... for the third time! The fix was done after M2. So installing M2 will not get you the fix. Your options are:

        • Update from nightly
        • wait for the release
        • use the workaround people suggested above.
        Show
        Kris De Volder (c) added a comment - Okay... for the third time! The fix was done after M2. So installing M2 will not get you the fix. Your options are: Update from nightly wait for the release use the workaround people suggested above.

          People

          • Assignee:
            Kris De Volder (c)
            Reporter:
            Fred Janon
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: