Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.0.0.RELEASE
    • Fix Version/s: None
    • Component/s: INTEGRATION
    • Environment:

      Eclipse Juno(4.2) Marketplace

      Description

      Can't instal "Spring Tool Suite (STS) for Eclipse Juno (4.2)" via Eclipse marketplace.

      Scenario:
      1) Open Eclipse (x32 or x64 versions)
      2) GoTo Help -> Eclipse Marketplace...
      3) Find: Spring Tool Suite
      4) Cklick "Go"
      5) Click "Install" on "Spring Tool Suite (STS) for ... (4.2)"
      6) Wait
      7) Showed Spring features tree
      8) Error.

      Error log:

      Unable to read repository at http://dist.springsource.com/release/TOOLS/update/e4.2/compositeContent.xml.
      Read timed out

      Some reason via "Instal new software" at URL http://dist.springsource.com/release/TOOLS/update/e4.2

      Installing Spring in Eclipse Helios Warketplace is working properly.

        Activity

        Martin Lippert (c) added a comment -

        I haven't heard back from our network admins, so I will bother them again. Seems like a crazy network issue... In the meantime, you can use the download.springsource.com version of that URL, right? (as mentioned above)

        Helmut Pasch added a comment -

        Yes download from

        Spring-Source - http://download.springsource.com/release/TOOLS/update/3.1.0.RELEASE/e4.2/

        worked for me.

        The download install was very slow, maybe the whole problem is connected to a load problem? During the installation process Eclipse connected to the http://dist.springsource.com/release/TOOLS/update/e4.2/compositeContent.xml site again to look for updates. I don't no, but might be the reason why installation also on the download.springsource.com was slow?

        Martin Lippert (c) added a comment -

        We are planning to move everything onto download.springsource.com, so that we don't use the dist.springsource.com anymore, even not for the main update site URLs. So please go ahead and change the URL for the "dist.springsource.com" update sites in your preferences to point to "download.springsource.com" instead. That should also avoid Eclipse connecting the dist.springsource.com site while installing something from somewhere else (I guess the "check all available update sites" was enabled in the "install new software" wizard, right?)

        vaadim sh added a comment -

        OK. That's worked now
        How can i close this issue?

        Martin Lippert (c) added a comment -

        Thanks for the feedback. I can close this for you.


          People

          • Assignee:
            Martin Lippert (c)
            Reporter:
            vaadim sh
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: