Spring Tool Suite
  1. Spring Tool Suite
  2. STS-2864

run a profiler (Eclipse Memory Analysis Tools) on the Spring Config Editor

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0.RELEASE
    • Fix Version/s: 3.1.0.M1
    • Component/s: UI
    • Labels:

      Description

      From the forum post http://forum.springsource.org/showthread.php?129319-STS-3-0-(Really-Eclipse-Juno)-is-slow&p=423040#post423040

      I have just observed that, if I open XML files in a text or XML editor, the switching is very quick, like java and property files.
      But if I open XML files in Spring Config Editor, then it takes bit time. I am using spring integration and I liked using Spring Config editor, since I can see integration-graph etc details. And I think this is taking a bit time since its generating graph and other GUI components, but in earlier version of STS (2.9.2), there was no delays using that editor.

      May be this finding will help narrowing down the root cause?

      Also, I have captured few thread dumps but not sure how to send these, as I am bit new to community.

      I think, as of now I will keep using text/xml editor for working with XML files.

      Thanks.

        Activity

        Leo Dos Santos (c) added a comment -

        Found & fixed a couple of places in our code where some resources were hanging on to closed config editors, but there appear to be some areas in Eclipse platform code that aren't releasing or cleaning up resources because closed config editors remain in memory.

        Biggest consumers of memory in STS are the beans model and project caches, but nothing out of the ordinary there.


          People

          • Assignee:
            Leo Dos Santos (c)
            Reporter:
            Leo Dos Santos (c)
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: