Spring Tool Suite
  1. Spring Tool Suite
  2. STS-2688

Type Plugin execution not covered by lifecycle configuration: org.codehaus.mojo:exec-maven-plugin:1.2:exec (execution: default, phase: process-classes) pom.xml

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Complete
    • Affects Version/s: 2.9.2.RELEASE
    • Fix Version/s: 3.0.0.M3
    • Component/s: ROO
    • Labels:
    • Environment:

      ubuntu 12.04 32bit,jdk 1.7.4, STS 2.9.2, Roo 1.2.1

      Description

      After the roo command "web gwt setup" pom.xml has this error.

        Activity

        Arash added a comment -

        I have been trying to make the expense.roo application work in STS 2.9.2.RELEASE with no luck. However I have compiled a list of forums, blogs and groups that have tried to tackle the similar issue. It appears that GWT group has come up with the solution and the dynatablerf is certainly working magically in STS/Indigo with GWT2.4 via maven configuration. It doesn't seem that difficult to utilize the solution in STS but I am not any expert in maven unfortunately.

        Marked as resolved !!!
        gwt 2.4 upgrade fails due to Request Factory new validatioln system
        https://jira.springsource.org/browse/ROO-2799

        Unable to work with Roo GWT plugin
        http://forum.springsource.org/showthread.php?120042-Unable-to-work-wit-Roo-GWT-plugin

        Can’t compile with GWT 2.4
        http://forum.springsource.org/showthread.php?116544-Can-t-compile-with-GWT-2.4&p=385963&highlight=#post385963

        How to solve “Plugin execution not covered by lifecycle configuration” for Spring Data Maven Builds
        http://stackoverflow.com/questions/6352208/how-to-solve-plugin-execution-not-covered-by-lifecycle-configuration-for-sprin

        Some Spring ROO 1.2 M1 GWT addon feedback (with GWT 2.4)
        http://forum.springsource.org/showthread.php?114675-Some-Spring-ROO-1-2-M1-GWT-addon-feedback-(with-GWT-2-4)

        Type Plugin execution not covered by lifecycle configuration: org.codehause.mojo:exec-maven-plugin:1.2:exec
        https://issuetracker.springsource.com/browse/STS-2688?page=com.atlassian.streams.streams-jira-plugin:activity-stream-issue-tab

        RequestFactoryInterfaceValidation
        http://code.google.com/p/google-web-toolkit/wiki/RequestFactoryInterfaceValidation

        Do RF validation via APT instead of commandline
        https://groups.google.com/forum/#!topic/google-web-toolkit-contributors/-4gaablGx8I

        The RequestFactory ValidationTool must be run for the RequestFactory type
        https://groups.google.com/forum/?fromgroups#!topic/google-web-toolkit/aMU21e02Ns0

        The most promising ones:

        guide to m2e, indigo, annotation processors and gwt
        https://groups.google.com/forum/#!topic/codehaus-mojo-gwt-maven-plugin-users/Lha85tfYiz4

        working with maven and requestfactory
        http://googlewebtoolkit.blogspot.com/2011/09/working-with-maven-and-requestfactory.html

        Alan Egerton added a comment -

        Unless I'm much mistaken, it's due to the following bug in AJDT:

        https://bugs.eclipse.org/bugs/show_bug.cgi?format=multiple&id=344159

        Andrew Eisenberg (c) added a comment -

        This could be related. But what kind of annotation processors does GWT use? Is it Java 6 style or Java 5 style? It used to be Java 5 style, but they may have changed things.

        Andrew Eisenberg (c) added a comment -

        No, does not look like they use Java 6 annotations, so it is not related to the bug that you link to.

        I'll have a look.

        Andrew Eisenberg (c) added a comment -

        I almost have it working and at this point I no longer think that the problem is with STS (or with Roo for that matter).

        First, for the title of this post, see:
        http://forum.springsource.org/showthread.php?116189-STS-2-8-0-and-m2e-FAQ-%28updated-for-STS-2-8-1%29

        Here's what you can do:

        1. Install the maven-exec-plugin m2e configurator from the m2e catalog.
        2. Alternatively, you can use the quickfix to mark the plugin as ignore}}d and then change {{ignore to execute.
        3. Then select the project, right-click -> Run as -> Maven build...
        4. Choose gwt:run as the goal
        5. wait for the gwt window to popup and open the link in your browser.

        At this point, I am unable to install the gwt browser plugin in Chrome, Firefox, or Safari for various compatibility reasons. That's not too say that if I looked a little harder that I might find an answer. This implies to me that the problem is not with STS or Roo, but with browser compatibility.

        Are you seeing the same problem and can you get to the same stage?

        Dmitry added a comment - - edited

        Andrew, thank you very much for you reply. Now I managed to escape Umbrella error in browser and application seems to be running, at least I managed to add Employee in expenses example))) What I did:

        1. m2e was installed. I also changed some way pom.xml, and there were also installations of two plugins, required by GWT (repository-apt and helper) in accordance to GWT articles and forum references - thanx to Arash' comment.
        2. quick fix was applied, but I did not changed it back to execute because now I do not know where to do it (I am very new in Java development).
        3. according to your comment, I executed Run as -> Maven build, gwt:run as the goal,
          and project seems to be working.
          As for me, I think that problem was (also) in Run procedure: previuosly I did Run As-> Web Application

        Within a week I promise to provide more information.
        I plan to:

        1. make fresh expenses project in STS
        2. apply quick fix
        3. try to run maven build
          About browser plugin, I work with the latest Crome, now on 64-bit Ubuntu , but the plugin was warking also on 32-bit Ubuntu/Chrome.
        Dmitry added a comment - - edited

        Final: to run expenses.roo

        1. read Arash comment and follow references - some plugins must be added to STS. I experimented, so I do not have a concrete answer. My STS should have m2e + 2 GWT-must plugins.
        2. create Roo project in STS, run script expenses.roo
        3. apply quick fix to pom.xml (ignore 2 errors); open Project Properties - Google - Web Toolkit, choose SDK and press OK. SDK should appear in your project root.
        4. remove <PluginManagement> section from pom.xml, if presented
        5. in pom.xml, just after the <build>, add the following:
          <!-- dp beg -->
          <pluginManagement>
          	<plugins>
          		<!--This plugin's configuration is used to store Eclipse m2e settings 
          			only. It has no influence on the Maven build itself. -->
          		<plugin>
          			<groupId>org.eclipse.m2e</groupId>
          			<artifactId>lifecycle-mapping</artifactId>
          			<version>1.0.0</version>
          			<configuration>
          				<lifecycleMappingMetadata>
          					<pluginExecutions>
          						<pluginExecution>
          							<pluginExecutionFilter>
          								<groupId>org.datanucleus</groupId>
          								<artifactId>maven-datanucleus-plugin</artifactId>
          								<versionRange>[1.1.4,)</versionRange>
          								<goals>
          									<goal>enhance</goal>
          								</goals>
          							</pluginExecutionFilter>
          							<action>
          								<ignore></ignore>
          							</action>
          						</pluginExecution>
          						<pluginExecution>
          							<pluginExecutionFilter>
          								<groupId>net.kindleit</groupId>
          								<artifactId>maven-gae-plugin</artifactId>
          								<versionRange>[0.7.3,)</versionRange>
          								<goals>
          									<goal>unpack</goal>
          								</goals>
          							</pluginExecutionFilter>
          							<action>
          								<execute />
          							</action>
          						</pluginExecution>
          						<pluginExecution>
          							<pluginExecutionFilter>
          								<groupId>
          									org.codehaus.mojo
          								</groupId>
          								<artifactId>
          									exec-maven-plugin
          								</artifactId>
          								<versionRange>
          									[1.2,)
          								</versionRange>
          								<goals>
          									<goal>exec</goal>
          								</goals>
          							</pluginExecutionFilter>
          							<action>
          								<ignore></ignore>
          							</action>
          						</pluginExecution>
          					</pluginExecutions>
          				</lifecycleMappingMetadata>
          			</configuration>
          		</plugin>
          	</plugins>
          </pluginManagement>
          <!-- dp end -->
          
        6. execute Run as -> Maven build, type gwt:run as the goal
        7. when GWT run opens, press "copy to clipboard", open Google Chrome, paste link and wait loading.. for 5-10 minutes
          That works for me
        Andrew Eisenberg (c) added a comment -

        Great. Resolving this issue.


          People

          • Assignee:
            Andrew Eisenberg (c)
            Reporter:
            Dmitry
          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: