Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: User Error
    • Affects Version/s: 3.0.0.M1
    • Fix Version/s: None
    • Component/s: UI
    • Labels:
      None
    • Environment:

      Description

      I tried opening up the Dashboard view (to get to extensions) to ensure Gradle was installed. and it came up 'blank'/ empty. Any thoughts on why this might happen?

      Error
      Tue May 08 23:59:34 EDT 2012
      Error creating dashboard part: "com.springsource.sts.ide.help.dashboard.part.tutorials"

      java.lang.NoClassDefFoundError: com/springsource/sts/internal/ide/ui/StsUiImages
      at com.springsource.sts.internal.ide.help.TutorialDashboardPart.getImage(TutorialDashboardPart.java:227)
      at com.springsource.sts.internal.ide.help.TutorialDashboardPart.createTutorialLinks(TutorialDashboardPart.java:207)
      at com.springsource.sts.internal.ide.help.TutorialDashboardPart.createPartContent(TutorialDashboardPart.java:100)
      at com.springsource.sts.ide.ui.AbstractDashboardPart.createControl(AbstractDashboardPart.java:32)
      at com.springsource.sts.ide.ui.AbstractDashboardPage.initializePart(AbstractDashboardPage.java:188)
      at com.springsource.sts.ide.ui.AbstractDashboardPage.access$0(AbstractDashboardPage.java:185)
      at com.springsource.sts.ide.ui.AbstractDashboardPage$1.run(AbstractDashboardPage.java:176)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      at com.springsource.sts.ide.ui.AbstractDashboardPage.createParts(AbstractDashboardPage.java:159)
      at com.springsource.sts.ide.ui.AbstractDashboardPage.contributeParts(AbstractDashboardPage.java:150)
      at com.springsource.sts.internal.ide.ui.editors.DashboardMainPage.createFormContent(DashboardMainPage.java:1320)
      at org.eclipse.ui.forms.editor.FormPage$1.run(FormPage.java:152)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
      at org.eclipse.ui.forms.editor.FormPage.createPartControl(FormPage.java:150)
      at org.eclipse.ui.forms.editor.FormEditor.pageChange(FormEditor.java:471)
      at org.eclipse.ui.part.MultiPageEditorPart.setActivePage(MultiPageEditorPart.java:1067)
      at org.eclipse.ui.forms.editor.FormEditor.setActivePage(FormEditor.java:603)
      at org.eclipse.ui.forms.editor.SharedHeaderFormEditor.createPages(SharedHeaderFormEditor.java:103)
      at org.eclipse.ui.part.MultiPageEditorPart.createPartControl(MultiPageEditorPart.java:348)
      at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)
      at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)
      at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
      at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:313)
      at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:180)
      at org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFolder.java:270)
      at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder.java:65)
      at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:473)
      at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1245)
      at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1198)
      at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:1597)
      at org.eclipse.ui.internal.PartStack.add(PartStack.java:493)
      at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:103)
      at org.eclipse.ui.internal.PartStack.add(PartStack.java:479)
      at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:112)
      at org.eclipse.ui.internal.EditorSashContainer.addEditor(EditorSashContainer.java:63)
      at org.eclipse.ui.internal.EditorAreaHelper.addToLayout(EditorAreaHelper.java:225)
      at org.eclipse.ui.internal.EditorAreaHelper.addEditor(EditorAreaHelper.java:213)
      at org.eclipse.ui.internal.EditorManager.createEditorTab(EditorManager.java:808)
      at org.eclipse.ui.internal.EditorManager.openEditorFromDescriptor(EditorManager.java:707)
      at org.eclipse.ui.internal.EditorManager.openEditor(EditorManager.java:666)
      at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2942)
      at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2850)
      at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2842)
      at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2793)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
      at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2789)
      at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2773)
      at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2756)
      at com.springsource.sts.internal.ide.ui.actions.ShowDashboardPageAction.run(ShowDashboardPageAction.java:55)
      at com.springsource.sts.internal.ide.ui.IdeUiPlugin$1$1.run(IdeUiPlugin.java:85)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3563)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3212)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
      at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
      Caused by: java.lang.ClassNotFoundException: com.springsource.sts.internal.ide.ui.StsUiImages
      at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:513)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:429)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:417)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      ... 75 more

        Activity

        Martin Lippert (c) added a comment -

        This exception looks like your installation got somehow into a broken state. What version of the bundle com.springsource.sts.ide.ui is installed in your setting?

        And can you check the list of available update sites (Preferences -> Install/Update -> Available Update Sites) to check if there is something in that list that points to a milestone or shapshot site?

        (The easiest way to fix this would be to install a fresh copy of STS from the distribution packages. Another workaround might be to take a look at the installation history, find out when some milestone or snapshot versions of STS got installed into your setting and revert the installation back to the state before that, but I don't know how reliable this is and if that works in every case. But maybe worth a try)

        Brian Bonner added a comment -

        Martin, you probably hit the nail on the head.

        I had this: but I didn't think it would effect all of STS.
        http://dist.springsource.com/milestone/TOOLS/third-party/groovy-grails/e3.7

        I also had: http://dist.springsource.com/milestone/TOOLS/gradle

        I must have left that there when I was looking at 2.9 M1 or one of them 2.7, 2.8, etc. Damn!

        Is there an easy way to install a fresh copy w/o having to reinstall all my plugins and configs??

        Martin Lippert (c) added a comment -

        I am afraid, but I think the "easiest" way to get a fresh install is to download the STS distribution and install your additional plugins afterwards again. But you can reuse your existing workspace with all its settings, you don't need to create a new one.

        You could also try to revert your installation back to an installation state from some time before the problematic update. Go to the about dialog, installation details, look for the history and try the revert feature. Maybe that works as well, but I have mixed experiences with that.

        Martin Lippert (c) added a comment -

        (maybe marking this as "user error" is not exactly correct, since this could happen by accident quite easily, but that was the best matching category that I found)

        Brian Bonner added a comment -

        no worries. User Error sounds accurate: Id10t or Pebkac also seem valid.

        I'll inventory my plugins and do a fresh install.


          People

          • Assignee:
            Unassigned
            Reporter:
            Brian Bonner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: