Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.9.1.RELEASE
    • Fix Version/s: None
    • Component/s: GRAILS
    • Labels:
      None
    • Environment:

      I am on Mac 10.7.3.
      STS 2.9.1.

      Description

      I have both groovy and grails installed on my mac commandline environment. I can create/run grails without problem.
      I installed latest sts 2.9.1 and installed groovy/grails in STS too. It worked. I was able to create create grails project and run it. I also imported a project created from commandline and it worked too.
      Then I imported the root directory of the project and setup git for the project. Then I noticed grails/groovy disappeared. The project was able to be compiled. But I cannot run it as grails app. The run grails app option disappeared. Groovy code also has problem. println and def are not recognized so treated as undefined.
      Here are some dialogs on grails user group:
      Here are more information:
      Grails 2.0.1
      STS 2.9.1
      Groovy 1.8

      The problem is: grails wizard is not listed anywhere when I goto File->new, grails is not listed under Other either. So I cannot create a grails project on STS.

      For existing project, i can still compile without error. But when I open groovy code, it shows
      println, def as undefined.

      Grails and groovy are installed for sure.

      Open the STS 'About SpringSource Toolsuite' dialog. Click on the
      springsource icon and a list of installed features will appear. Is
      grails listed there as 'com.springsource.sts.grails' - if so what
      version?

      Open the error log (Window>ShowView>ErrorLog) - anything in there to
      explain why it has been de-activated?

      Worth raising a jira at the STS issue tracker to pursue this:
      https://issuetracker.springsource.com/browse/STS

      cheers,
      Andy

      Thanks. On about sts features, version 2.9.1.201203221000-release displayed for com.springsource.sts.grails
      From windows->show view-> I didn't see error log
      I have both groovy and grails installed on environment and sts. I have older app created from command line and imported one of them into Sts. The imported one was also compiled.
      Does this provide any clue ?
      > Thanks. On about sts features, version 2.9.1.201203221000-release displayed for com.springsource.sts.grails

      Ok, so you do definetly have the grails stuff installed.

      > From windows->show view-> I didn't see error log

      That's strange, I just double checked the path and it should definetly
      be there. The Error Log tracks all the errors that happen in the
      background whilst using eclipse.

      Another way to see some of that information is to look in your
      workspace .metadata/.log file - that may contain a clue. I'd still
      recommend raising an STS jira so we can track it. (rather than
      attaching your full metadata log to a mailing list post).

      > I have both groovy and grails installed on environment and sts. I have older app created from command line and imported one of them into Sts. The imported one was also compiled.

      The description of your problem, that you have the Grails tools
      installed but cannot create a new Grails project (File>New>Grails
      Project) sounds familiar but I can't immediately find a related jira
      in our issue tracker.

      Do you have the grails perspective (Window>Open Perspective>Other...>Grails)?

      I'd still say raise a jira and we can progress it there.

      1. log.txt
        140 kB
        Yiguang Hu
      2. log.txt
        140 kB
        Yiguang Hu

        Activity

        Yiguang Hu added a comment -

        I would appreciate a work around to let me move on before the issue is fixed. Thanks

        Kris De Volder (c) added a comment -

        Hi Yiguang,

        > I would appreciate a work around to let me move on before the issue is fixed.

        I understand. I'm sorry for your troubles. Unfortunately your problem is quite puzzling and I don't know what might be causing it so suggesting a workaround that may work is hard.

        What is puzzling me is that the behavior that you describe sounds as if Groovy / Grails tools are not even installed. Yet you confirmed that they are indeed installed. You also say that the error log view is missing.

        It sounds to me as if something may have gotten corrupted in your STS installation. There are a few things that you could try. But I can't guarantee it will work.

        THe first thing you might try is start STS from the commandline with the -clean option. This should clear out cached information about installed plugins etc.

        If that doesn't help, another thing you could try next is start STS on a fresh and empty workspace. Then try to import your project in the new workspace.

        If that also doesn't work I'm afraid I only have one thing left to suggest. Try to reinstall STS and the groovy and Grails tools (I would try that last since you want to avoid it if possible).

        Also, before doing any of this, if you can find the error log as Andy suggested. The errors in the log might give us a clue on what is causing your problems. Since the error log viewer is not working you will have to find the log file on disk. If $

        {workspace} is the location of your workspace. Then the log file can be found here:

        ${workspace}

        /.metadata/.log

        If you can find that file and attach its contents to this issue that might be helpful.

        Kris

        Yiguang Hu added a comment -

        Thanks. At least I find the log. I also find the grails perspective but it is put in between <>. So it doesn't help. I am attaching the log here. I suspect the problem is egit related.

        Yiguang Hu added a comment -

        log file of the issue

        Kris De Volder (c) added a comment -

        Perpsective between '<>' points at the same thing as all the other things you said. I.e. it is a typical symptom of the Grails tools not being installed (or somehow being corrupted or conflicting so they don't actually get loaded at runtime).

        I took a look through your log file. Unfortunately I don't see any errors related to loading the grails / groovy plugins. There was one plugin startup related error involving an m2e plugin (maven support plugins).

        Maybe it is related, but it is a long shot. Still you could try uninstalling the maven tools (I am assuming you don't need maven support, you don't need it for Grails in any case, but you may actually need it for something else, you should know).

        If you want to try that (Go to "Help >> install new software" Click "What is already installed" link... Find anything with 'Maven' or 'm2e' in it and uninstall this.)

        Also, did you already try to run with -clean as suggested? It would be my best bet when STS seems confused about starting / loading plugins.

        If that doesn't work, unfortunately I haven't got much else to suggest. It seems to me your installation has somehow gotten damaged, I don't know how or what is wrong with it, so you may need to reinstall it from scratch.

        Kris

        Kris De Volder (c) added a comment -

        There has been no traffic on this for a while. Since this isn't a problem I can reproduce or further diagnose at this point I'm closing it.

        However, if you still need help with this problem please feel free to add more messages/questions to this issue, we can always reopen it.


          People

          • Assignee:
            Kris De Volder (c)
            Reporter:
            Yiguang Hu
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: