Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Works as Designed
    • Affects Version/s: 2.9.1.RELEASE
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Not able to perform any software updates - getting this error "No repository found at file:filePath"

      – Configuration Details –
      Product: SpringSource Tool Suite 2.9.1.201203221000-RELEASE (com.springsource.sts.ide)
      Installed Features:
      com.springsource.sts 2.9.1.201203221000-RELEASE

        Activity

        Martin Lippert (c) added a comment -

        Do you get exactly this error message including "file:filePath"? Or did you put this in here as a placeholder for something else? I am asking because I've never seen this. The usual problems with accessing update sites are proxy/firewall issues. What happens when you open up the "install new software" dialog and select the STS update site from there, for example?

        Martin Lippert (c) added a comment -

        Can you take a look at the version of the bundle org.eclipse.jdt.ui that is installed in your STS?

        LifeSaviour made changes -
        Field Original Value New Value
        Attachment screenshot-1.jpg [ 16055 ]
        LifeSaviour added a comment -

        Somehow I have 3 installed on my machine:

        org.eclipse.jdt.ui_3.7.2.v20120109-1427.jar
        org.eclipse.jdt.ui_3.7.2.r372_v20111109-0800.jar
        org.eclipse.jdt.ui.prefs

        LifeSaviour made changes -
        Attachment screenshot-2.jpg [ 16056 ]
        LifeSaviour made changes -
        Attachment screenshot-1.jpg [ 16055 ]
        Martin Lippert (c) added a comment -

        I think my question above for the JDT version was an error on my side, please discard it. Sorry for that.

        Can you take a look at your preferences for the used update sites? (Preferences -> Install/Update -> Available Software Sites)
        Do you see anything in there that looks like the URL STS is complaining about? If so, please delete it from the list and try again.

        LifeSaviour added a comment -

        That's resolved now. Many Thanks!

        Martin Lippert (c) made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Works as Designed [ 15 ]
        Trevor Marshall (c) made changes -
        Workflow jira [ 42855 ] jira with Pivotal Tracker [ 66875 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        24d 12h 31m 1 Martin Lippert (c) 09/May/12 4:41 AM

          People

          • Assignee:
            Unassigned
            Reporter:
            LifeSaviour
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: