Spring Tool Suite
  1. Spring Tool Suite
  2. STS-2573

Ivy dependency missing from Grails project

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0.M1
    • Component/s: GRAILS
    • Labels:
      None

      Description

      I'm running the nightly build of STS for Eclipse 4.2, and my Grails 1.3.7 project is having an error resolving an Ivy class reference in our BuildConfig.groovy file. This looks similar to http://jira.grails.org/browse/GPRELEASE-24 and https://issuetracker.springsource.com/browse/STS-2084.

      I've been able to work around the issue by adding

       build "org.apache.ivy:ivy:2.2.0" 

      to the dependencies, but I'm expecting a lot of grumbling from the InteliJ users on the team about this.

        Activity

        Kris De Volder (c) added a comment -

        Right. It also looks similar to this:
        http://jira.grails.org/browse/GRAILS-8956

        My guess is that the 'missing ivy jar' problem has existed in both plugins and regular apps for a while. But it only comes to light if there is actually something in your code or a plugin's code that makes reference to ivy classes.

        I'm not sure it is worth for me to do a similar 'patchy workaround' in STS specific to Grails 1.3.7 (and 1.3.8?). It won't fix your problem until you upgrade STS Grails support to a version that has my fix (that would likely be 3.0, unless you are ok working from a nightly snapshot.

        Since the problem is supposed to be fixed in Grails 2.0.3, depending on how serious this problem is for you maybe you could upgrade your project to 2.0.3 (I realize that may not be trivial

        Anyhow, I can certainly and easily broaden the scope of the 'fix' I put in for STS-2084. Just not sure how useful it would be. (I.e. what I'm saying is that if you think it will actually help you, I will do so, otherwise I'm inclined to close this issue as won't fix).

        Kris

        Jason Gritman added a comment -

        Unfortunately, upgrading to Grails 2.0.x won't happen for a few months for us.

        If it's not too much work to get this in the STS 3.0 nightly builds, that would solve this problem since I update to the nightly every day. However, I can still work without the fix, so it's not that critical that I have it.

        Thanks,

        -Jason

        Kris De Volder (c) added a comment -

        Closing issue.

        I've pushed a change that broadens the fix for
        STS-2084 to also add the ivy-jar for Grails 1.3.7 and 1.3.8 projects.

        Kris De Volder (c) added a comment - - edited

        Fix should be available from the nightly update site by tommorrow. If you could confirm it works for you that would be nice. (Or if it doesn't, in which case I should take another look

        Cheers,

        Kris

        Jason Gritman added a comment -

        Sorry just got around to testing this and it works now. Thanks for your help!

        Kris De Volder (c) added a comment -

        Great! Thanks for letting me know.


          People

          • Assignee:
            Kris De Volder (c)
            Reporter:
            Jason Gritman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: