Spring Tool Suite
  1. Spring Tool Suite
  2. STS-2499

Debug evaluations do not work in specific situation

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Complete
    • Affects Version/s: 2.9.0.RELEASE
    • Fix Version/s: 3.0.0.M1
    • Component/s: GRAILS
    • Labels:
      None

      Description

      When the current file is in a package with more than one segment and there is a second top level class in the same file, evaluation is broken.

      Eg-

      package a.b
      
      class First {
        static final main(args) {
          def x = 0
          println x  // set breakpoint here and evaluate. exception is thrown.
        }
      }
      

        Activity

        Andrew Eisenberg (c) added a comment -

        I have a fix. It turns out that I was not converting from a qualified name to a simple name correctly in the synthetic eval script. I made the change and now I am writing a few more tests. Will commit soon.

        Andrew Eisenberg (c) added a comment -

        Fix is committed with regression tests.


          People

          • Assignee:
            Andrew Eisenberg (c)
            Reporter:
            Andrew Eisenberg (c)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: