Spring Tool Suite
  1. Spring Tool Suite
  2. STS-2493

Spring nature not automatically added when project has spring-core dependency

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Complete
    • Affects Version/s: 2.9.0.RELEASE
    • Fix Version/s: 2.9.2.RELEASE, 3.0.0.M1
    • Component/s: MAVEN
    • Labels:
      None

      Description

      I was looking forward to the fix for: STS-2322

      However, it appears there is a bug in it. I still do not get the spring nature set if I have spring-core in my project but don't have the old maven-eclipse-plugin configuration.

      Debugging into the issue it appears the problem is with com.springsource.sts.maven.internal.core.SpringProjectConfigurator.

      It sets "found" to false. And then when spring-core is found and "addProjectNature" is called it doesn't set "found" to true. So processing continues to configureNature() which removes the spring nature if it cannot find it in the maven-eclipse-plugin.

        Activity

        Andrew Eisenberg (c) added a comment -

        What version of m2eclipse are you using?

        We only implemented STS-2322 for m2eclipse V1.x (the new version). We have not implemented it for the legacy version that is still supported but is not as feature-rich as the new version is.

        If you want to upgrade, you can do so on the STS dashboard extensions page.

        Mike Youngstrom added a comment -

        I'm using the same m2e that was released with indigo SR2. I was hoping you could just look at SpringProjectConfigurer and you'd see that "found" was not being set to true. But I guess I'll have to make a test case now.

        Andrew Eisenberg (c) added a comment -

        Ah...silly. I got it. Thanks for pointing out the problem. I'll try out the fix and the commit it. This should be available on the snapshot branch tomorrow.

        Andrew Eisenberg (c) added a comment -

        Available in 2.9.1 release.

        Mike Youngstrom added a comment - - edited

        This appears to still not be fixed in 2.9.1. When looking at SpringProjectConfigurator I see the same code. Still not setting found = true after line 39.

        And I'm still experiencing the same behavior.

        Martin Lippert (c) added a comment -

        It looks like the fix didn't made it into the 2.9.x maintenance branch. I will fix that. Should be available as part of STS 2.9.2 and from the nightly builds since March 10, 2012.

        Martin Lippert (c) added a comment -

        btw: did you decompile STS for this? Just asking...

        Mike Youngstrom added a comment -

        Yes, sorry. Sometimes it just makes debugging problems easier. Now I will promptly delete this comment so that I don't get my license revoked. I heard at SpringOne that there was work to Open Source STS. Please hurry!

        Martin Lippert (c) added a comment -


        STS 3.0 (to be released by July/August) will be based on the open-source repositories at GitHub by then, but the individual repositories might show up a lot earlier...

        Mike Youngstrom added a comment -

        Good news! I look forward to it. Now you better delete your comment before someone finds it and turns it into a release commitment.

        Martin Lippert (c) added a comment -

        Hehe... We have public release dates for STS now for quite a while, shipping roughly quarterly releases (after Eclipse main release, SR1 and SR2) and we shipped those versions on time. So I am not afraid of letting everybody know that STS 3.0 is planned to ship quickly after the Eclipse Juno release. We might need some more time than usual this time (because of the open-sourcing shift), but aside from that I am pretty sure we will ship on time again.

        Mike Youngstrom added a comment -

        Excellent. Rock on!


          People

          • Assignee:
            Andrew Eisenberg (c)
            Reporter:
            Mike Youngstrom
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: