Spring Tool Suite
  1. Spring Tool Suite
  2. STS-2384

[tc server] Hard to recover from "bad" installation directory

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.0.M1
    • Fix Version/s: 2.9.0.RC2
    • Component/s: SERVER
    • Labels:

      Description

      If you enter in a "bad" installation directory for the TC server, then it is difficult to recover from that.

      Steps to reproduce:
      0. Launch Eclipse with a clean workspace.
      1. Go to the Servers view.
      2. Right click and select New->Server
      3. Select Spring Source->SpringSource tc Server v2.1 from the tree of possible servers.
      4. Press the Next button.
      5. Specify an installation directory which is good enough to pass a quick check but bad enough to be wrong later (e.g. plugins/com.springsource.sts.server.tc.tests/testdata/tc-server-developer-2.1.0.RELEASE).
      6. Click Finish.
      7. Run that server (which is wrong, a) because the directory has the wrong contents and b) because the instance wasn't created); get error messages.
      8. Go to the Servers view.
      9. Right click and select New->Server
      10. Select Spring Source->SpringSource tc Server v2.1 from the tree of possible servers.
      11. Select Next.

      At this point, you can't see that there was a problem with the directory, nor how to fix the directory. Yes, on the previous page, there was a note about "Configure runtime environments", but not on this page.

        Activity

        Steffen Pingel made changes -
        Field Original Value New Value
        Original Estimate 0h [ 0 ]
        Remaining Estimate 0h [ 0 ]
        Assignee Steffen Pingel [ spingel ]
        Fix Version/s 2.9.0.RC2 [ 11803 ]
        Steffen Pingel added a comment -

        Addressed as part of STS-2446.

        Steffen Pingel made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 8 ]
        Steffen Pingel made changes -
        Labels y5m6
        Trevor Marshall (c) made changes -
        Workflow jira [ 40147 ] jira with Pivotal Tracker [ 64365 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        33d 7h 49m 1 Steffen Pingel 15/Feb/12 2:06 AM

          People

          • Assignee:
            Steffen Pingel
            Reporter:
            Leo Dos Santos (c)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: