Spring Tool Suite
  1. Spring Tool Suite
  2. STS-2333

DSL support for Grials integration tests not very good.

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Works as Designed
    • Affects Version/s: 2.8.1.RELEASE
    • Fix Version/s: 2.9.0.M1
    • Component/s: GRAILS
    • Labels:

      Description

      The test DSL in integration tests is different from that of the unit tests. Typically, @TestFor and @Mock are not used in these tests. There is documentation here:
      http://grails.org/doc/2.0.0.RC3/guide/testing.html#integrationTesting

      Part of this work is dsld, and part of this is STS work. I don't know if I will be able to fix this for 2.9.0.M1.

        Activity

        Andrew Eisenberg (c) added a comment -

        I am closing this as "Works as designed". After a bit more combing through the docs of integration testing, it looks like there is no meta-programming magic going on for integration tests. And all pieces of integration testing is fully supported in the editor already.


          People

          • Assignee:
            Andrew Eisenberg (c)
            Reporter:
            Andrew Eisenberg (c)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: