Spring Tool Suite
  1. Spring Tool Suite
  2. STS-2331

Duplicate Dependency Management nodes in project properties

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.1.RELEASE
    • Fix Version/s: 2.9.0.M1
    • Component/s: MAVEN
    • Labels:
    • Environment:

      Windows 7, Java 7, Eclipse 3.7.1

      Description

      After installing STS from the update site I see two entries for Development Management in project properties. The pages for those nodes are identical and contain only one checkbox. If I check that checkbox on one of the pages and close and reopen project properties, it will also appear on the other page.

      1. STS01.png
        36 kB
      2. STS02.png
        37 kB
      3. STS03.png
        37 kB
      4. STS04.png
        36 kB
      5. STS05.png
        36 kB

        Issue Links

          Activity

          Aleksandr Tarutin added a comment -

          STS03 and STS04.png show that only one is checked.
          STS05.png shows that the state of the page "replicated" the other page.

          Aleksandr Tarutin made changes -
          Field Original Value New Value
          Attachment STS01.png [ 15128 ]
          Attachment STS02.png [ 15129 ]
          Attachment STS03.png [ 15130 ]
          Attachment STS04.png [ 15131 ]
          Attachment STS05.png [ 15132 ]
          Andrew Eisenberg (c) added a comment -

          The problem is that you have components from both the new m2eclipse and the old m2eclipse. When you go to Help -> About STS, you will only see one m2eclipse icon, but secretly there are components from the other version. I am not sure which one you have, but I am guessing that you explicitly installed either 0.12 or 1.0 of m2eclipse and then installed a configurator or two that targeted the other version.

          To solve:

          1. go to sts dashboard
          2. open extensions page
          3. scroll down until you see m2eclipse. This will be the other version of m2eclipse (the one that you did not install explicitly)
          4. select this and click install. This will first uninstall all m2eclipse components and then re-install just the components of the other m2eclipse.
          5. After installing, restart.
          6. You should now only see one dependency management page.
          7. if this is not the m2eclipse version that you want, go back to the extensions page and find m2eclipse, select it and re-install.
          Aleksandr Tarutin added a comment -

          Something along these lines worked. Thank you.

          The difference was that after step 4 I got an error and after I restarted eclipse I could see m2eclipse 1.0 in Dashboard.

          Installed that and it all worked wonderfully.

          Thanks again,

          AT.

          Andrew Eisenberg (c) added a comment -

          closing.

          Andrew Eisenberg (c) made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Labels maven
          Assignee Andrew Eisenberg [ aeisenberg ]
          Fix Version/s 2.9.0.M1 [ 11799 ]
          Resolution Fixed [ 8 ]
          Aleksandr Tarutin added a comment -

          Another way of resolving this is to uninstall SpringSource Tool Suite Maven Support (com.springsource.sts.maven.feature.group).

          The issue is still present in STS-2.9.0-M1.

          Andrew Eisenberg (c) added a comment -

          Can yiou be more specific as to how exactly you got into the bad state?

          How did you start? What did you install? Did you install from dashboard or from install manager? Did you do "Check for updates"?

          will vuong added a comment -

          I just installed STS 2.9 via the windows installer, created a new blank Java project in a new workspace, opened up project properties, and noticed the duplicate Dependency Management nodes. So it doesn't look resolved.

          Martin Lippert (c) added a comment -

          Do you see multiple Dependency Management nodes on the main level of the project properties page or under the Spring category?

          will vuong added a comment -

          On the main level.

          Martin Lippert (c) added a comment -

          Hmmm... right, I can confirm this and its a bug.
          That case is a duplicate of this: https://issuetracker.springsource.com/browse/STS-2532
          Therefore I will keep this closed as a duplicate, work on this will continue in STS-2532.

          Andrew Eisenberg (c) made changes -
          Link This issue is duplicated by STS-2532 [ STS-2532 ]
          Andrew Eisenberg (c) added a comment -

          I am currently working on STS-2532. I believe that it is working now, but it is a tricky thing to test and I don't want to release before I am certain.

          Trevor Marshall (c) made changes -
          Workflow jira [ 39199 ] jira with Pivotal Tracker [ 66342 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          3d 17h 46m 1 Andrew Eisenberg (c) 13/Dec/11 9:17 AM

            People

            • Assignee:
              Andrew Eisenberg (c)
              Reporter:
              Aleksandr Tarutin
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                First Response Date: