Details

    • Type: Bug Bug
    • Status: Open Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 2.8.0.RELEASE
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Eclipse Indigo with STS, JBoss hibernate Tools & Papyrus plugins installed

      Description

      Every once in a while the Spring config editor disappears until a clean Eclipse installation is performed and the STS reinstalled.

      eclipse.buildId=I20110613-1736
      java.version=1.6.0_24
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
      Framework arguments: -product org.eclipse.epp.package.jee.product
      Command-line arguments: -os win32 -ws win32 -arch x86_64 -clean -product org.eclipse.epp.package.jee.product -clean

      Error
      Fri Nov 18 09:57:41 EET 2011
      Unable to create editor ID com.springsource.sts.config.ui.editors.SpringConfigEditor: No editor descriptor for id com.springsource.sts.config.ui.editors.SpringConfigEditor

      org.eclipse.ui.PartInitException: No editor descriptor for id com.springsource.sts.config.ui.editors.SpringConfigEditor
      at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:601)
      at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)
      at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
      at org.eclipse.ui.internal.EditorAreaHelper.setVisibleEditor(EditorAreaHelper.java:271)
      at org.eclipse.ui.internal.EditorManager.setVisibleEditor(EditorManager.java:1459)
      at org.eclipse.ui.internal.EditorManager$5.runWithException(EditorManager.java:972)
      at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
      at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:803)
      at org.eclipse.ui.internal.Workbench$33.runWithException(Workbench.java:1595)
      at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
      at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1386)

        Activity

        Hide
        Martin Lippert (c) added a comment -

        Interesting. What update site did you use before to install STS? And what features did you select?

        Show
        Martin Lippert (c) added a comment - Interesting. What update site did you use before to install STS? And what features did you select?
        Hide
        Christophoros Papachristophorou added a comment -

        I used the STS update site (springsource-tool-suite-2.8.0.RELEASE-e3.7.1-updatesite.zip) as well as the online update site from Springsource (http://dist.springsource.com/release/TOOLS/composite/e3.7/bookmarks.xml). On all times i only installed two components: The Spring IDE Core and The SpringSource tool Suite. It was the two only required components. All others were optional and did not install them as i didn't need them

        Show
        Christophoros Papachristophorou added a comment - I used the STS update site (springsource-tool-suite-2.8.0.RELEASE-e3.7.1-updatesite.zip) as well as the online update site from Springsource ( http://dist.springsource.com/release/TOOLS/composite/e3.7/bookmarks.xml ). On all times i only installed two components: The Spring IDE Core and The SpringSource tool Suite. It was the two only required components. All others were optional and did not install them as i didn't need them
        Hide
        Dustin Chesterman added a comment -

        I am also experiencing this issue. I originally installed STS 2.8, added Hibernate Tools, and upgraded STS to 2.9. I feel like the issue started when I upgraded but can't recall exactly. Is there a 'past versions' area I can get 2.8 and test this out?

        Show
        Dustin Chesterman added a comment - I am also experiencing this issue. I originally installed STS 2.8, added Hibernate Tools, and upgraded STS to 2.9. I feel like the issue started when I upgraded but can't recall exactly. Is there a 'past versions' area I can get 2.8 and test this out?
        Hide
        Martin Lippert (c) added a comment -

        You can download older releases from the standard download page, just click on the "Other Downloads" section at the end and all the other downloads will appear.

        Show
        Martin Lippert (c) added a comment - You can download older releases from the standard download page, just click on the "Other Downloads" section at the end and all the other downloads will appear.
        Hide
        Jim Kodet added a comment -

        This problem has been occurring for me, using the 'SpringSource University' USB device, which was handed out in the 'Core Spring' class. Everything works fine when I perform the initial installation, using the USB. However, after I'm prompted to perform updates, I receive 'Could not open the editor: No editor descriptor for id com.springsource.sts.config.ui.editors.SpringConfigEditor'. The files located on the USB files all have a timestamp of 6/19/2012.

        Show
        Jim Kodet added a comment - This problem has been occurring for me, using the 'SpringSource University' USB device, which was handed out in the 'Core Spring' class. Everything works fine when I perform the initial installation, using the USB. However, after I'm prompted to perform updates, I receive 'Could not open the editor: No editor descriptor for id com.springsource.sts.config.ui.editors.SpringConfigEditor'. The files located on the USB files all have a timestamp of 6/19/2012.

          People

          • Assignee:
            Martin Lippert (c)
            Reporter:
            Christophoros Papachristophorou
          • Votes:
            2 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              First Response Date: