Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.8.0.RELEASE
    • Fix Version/s: None
    • Component/s: GRADLE
    • Environment:

      Mac OS X 10.7.2
      STS 2.8.0
      Java 1.6.0_26

      Description

      I attempted to import a very basic Gradle project that used the Java plugin and nothing else (to compile 1 simple POJO and an associated unit test class) but after selecting the project and clicking Build Model a progress dialog popped up while STS attempted to download the Gradle zip file. At the time I had intermittent/no Internet connection but the cancel button wasn't enable. After waiting for approximately 4 minutes the timeout had still not timed out and I ended up killing STS.

        Activity

        Kyle Smith added a comment -

        Screenshot showing the progress dialog and disabled cancel button.

        Kris De Volder (c) added a comment -

        This is a known problem documented in the FAQ.
        See http://static.springsource.org/sts/docs/latest/reference/html/gradle/faq.html#a8

        There's nothing I can do about it unless this Gradle tooling API issue is adressed:
        http://issues.gradle.org/browse/GRADLE-1539

        Anyhow, I guess I'll keep your issue open... people keep re-raising it and I've closed previous duplicate issues already.

        Kyle Smith added a comment -

        Sorry, I think that's the first time I've ever seen the STS docs.

        Kris De Volder (c) added a comment -

        No problem. It's not always easy to find those things. I only know about the FAQ because I wrote it.

        I'd actually rather have you raise a bug report for a known issue than decide not to report an issue that we may not know about.

        Kris

        Kris De Volder (c) added a comment -

        Looks like this is a duplicate of another older open issue.
        STS-2070


          People

          • Assignee:
            Kris De Volder (c)
            Reporter:
            Kyle Smith
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: