Spring Tool Suite
  1. Spring Tool Suite
  2. STS-1944

Trying to install Adobe Flashbuilder 4.5 (as a plugin in STS 2.7.1)

    Details

    • Type: Bug Bug
    • Status: Open Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: 2.7.1.RELEASE
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows XP
      JDK 1.6.0.16
      2.7.1 Eclipse based on Eclipse 3.7

      Description

      I tried deploying the Adobe Flashbuilder Plugin on STS 2.7.1. I thought it should work fine.

      I downloaded FlashBuilder from here:

      and ran the installation as specified here:

      I ran the Eclipse plugin utility in: C:\Program Files\Adobe\Adobe Flash Builder 4.5\utilities

      The file is called: Adobe Flash Builder 4.5 Plug-in Utility.exe

      I specified the STS 2.7.1 when the utility asked for an eclipse installation. However, when I started STS, I could not find the Flash preference group in Windows->Preferences as it is normally supposed to be.

      Also when the P2 plugin manager tried to run it failed with the following msgs:

      I'm trying to get some insight into why this is failing.

      1. Adobe Flash Builder 4.5 Plug-in Utility installer.log
        12 kB
        Brian Bonner
      2. sts.log
        6 kB
        Brian Bonner

        Activity

        Hide
        Brian Bonner added a comment -

        For some reason this issue submitted accidentally:

        Once you download and install flash builder, here are the instructions to use it as a plugin.

        1. Complete the installation process as described above.
        2. Navigate to the installed Flash Builder installation location and open the utilities folder.
        3. Run the executable Adobe Flash Builder 4.5 Plug-in Utility.exe.
        4. Select the language and click on OK.
        5. Select the Flash Builder installation location if prompted.
        6. Select the Eclipse folder into which you want Flash Builder 4.5.1 to be plugged into and click Next. (Note: Your copy of Eclipse must be version 3.6 or later, 32-bit and must contain a folder named “dropins”)
        7. Review the pre-Installation summary and click on Install

        Here's the link for Flashbuilder: https://www.adobe.com/cfusion/tdrc/index.cfm?product=flash_builder

        Here are the error messages from P2:

        session context was profile=com.springsource.sts.ide, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
        No repository found containing: osgi.bundle,com.qnx.flashbuilder.multiplatform.qnx.ui,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.flexide.multiplatform.qnx,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.tools.bbt.core,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.tools.bbt.ui,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.tools.flashbuilder4.help,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.tools.flashbuilder45,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.flashbuilder.multiplatform.qnx.ui.examples,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.flashbuilder.multiplatform.qnx.ui.nl1,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.flexide.multiplatform.qnx.nl1,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.tools.bbt.core.nl1,1.1.0.201106171124
        No repository found containing: osgi.bundle,com.qnx.tools.bbt.ui.nl1,1.1.0.201106171124
        No repository found containing: org.eclipse.update.feature,com.qnx.tools.flashbuilder45,1.1.0.201106171124

        Show
        Brian Bonner added a comment - For some reason this issue submitted accidentally: Once you download and install flash builder, here are the instructions to use it as a plugin. 1. Complete the installation process as described above. 2. Navigate to the installed Flash Builder installation location and open the utilities folder. 3. Run the executable Adobe Flash Builder 4.5 Plug-in Utility.exe. 4. Select the language and click on OK. 5. Select the Flash Builder installation location if prompted. 6. Select the Eclipse folder into which you want Flash Builder 4.5.1 to be plugged into and click Next. (Note: Your copy of Eclipse must be version 3.6 or later, 32-bit and must contain a folder named “dropins”) 7. Review the pre-Installation summary and click on Install Here's the link for Flashbuilder: https://www.adobe.com/cfusion/tdrc/index.cfm?product=flash_builder Here are the error messages from P2: session context was profile=com.springsource.sts.ide, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,com.qnx.flashbuilder.multiplatform.qnx.ui,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.flexide.multiplatform.qnx,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.tools.bbt.core,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.tools.bbt.ui,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.tools.flashbuilder4.help,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.tools.flashbuilder45,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.flashbuilder.multiplatform.qnx.ui.examples,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.flashbuilder.multiplatform.qnx.ui.nl1,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.flexide.multiplatform.qnx.nl1,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.tools.bbt.core.nl1,1.1.0.201106171124 No repository found containing: osgi.bundle,com.qnx.tools.bbt.ui.nl1,1.1.0.201106171124 No repository found containing: org.eclipse.update.feature,com.qnx.tools.flashbuilder45,1.1.0.201106171124
        Hide
        Brian Bonner added a comment -

        Here's the log showing that everything should have been successful.

        Show
        Brian Bonner added a comment - Here's the log showing that everything should have been successful.
        Brian Bonner made changes -
        Field Original Value New Value
        Attachment Adobe Flash Builder 4.5 Plug-in Utility installer.log [ 13399 ]
        Hide
        Brian Bonner added a comment -

        Here's all that I found in the error log.

        Show
        Brian Bonner added a comment - Here's all that I found in the error log.
        Brian Bonner made changes -
        Attachment sts.log [ 13400 ]
        Hide
        Martin Lippert (c) added a comment -

        Hey Brian!

        I am not an expert for the Flash builder, but did you try to install this into a plain Eclipse Indigo JEE installation? Just would be interesting to see if the problem is specific to STS or also happens for Eclipse Indigo. Can you try that?

        Thanks,
        Martin

        Show
        Martin Lippert (c) added a comment - Hey Brian! I am not an expert for the Flash builder, but did you try to install this into a plain Eclipse Indigo JEE installation? Just would be interesting to see if the problem is specific to STS or also happens for Eclipse Indigo. Can you try that? Thanks, Martin
        Trevor Marshall (c) made changes -
        Workflow jira [ 34151 ] jira with Pivotal Tracker [ 65958 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Brian Bonner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              First Response Date: