Spring Tool Suite
  1. Spring Tool Suite
  2. STS-1889

Groovy editor got problems of resolving the full qualified class name in groovy class files

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.7.0.M2
    • Fix Version/s: 2.7.0.RELEASE
    • Component/s: EDITING
    • Labels:
    • Environment:

      kubuntu 10.04.2 LTS, jdk 1.6.24, grails 1.3.7, sts Version: 2.7.0.SNAPSHOT/Build Id: 201106260819

      Description

      When opening a groovy class file and viewing its source code the editor, it is not factoring in the default imports of groovy (java.util ... etc.)

      e.g.
      1) Opening groovy.util.ConfigObject.class of the groovy-all.jar (1.7.8)
      2) pointin the mouse over "new Properties()" in line 113
      the editor does not know that it is "java.util.Properties"
      instead it offers 3 possible Solutions:

      • com.sun.xml.internal.fastinfoset.sax.Properties
      • java.util.Properties
      • com.sun.xml.internal.stream.buffer.sax.Properties

        Activity

        Andrew Eisenberg (c) added a comment -

        This bug is covered under:
        http://jira.codehaus.org/browse/GRECLIPSE-866

        The problem is essentially that groovy classes coming in from binary are not yet recognized as groovy classes and so the Java parser/resolver tries to resolve references in them and (as you would expect) fails miserably.

        I have done a little bit of work in this area (primarily to remove synthetic members from appearing in the outline view and elsewhere), but much more work needs to be done.

        Until now, there haven't been many people screaming for this support, so I haven't spent much time on it. But, if you do want to see this happen, then make some noise.

        Konstantinos Kostarellis added a comment -

        This issue is rather minor (to me), as the priority indicates


          People

          • Assignee:
            Andrew Eisenberg (c)
            Reporter:
            Konstantinos Kostarellis
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: