Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.7.0.M2
    • Fix Version/s: 2.7.0.M3 (CF)
    • Component/s: CLOUDFOUNDRY
    • Labels:

      Description

      When I create cloud in STS (Manage Cloud), I am finding that the logic to validate is not right. For example (I am considering valid to mean "Ok" button enabled),

      Invalid considered valid: http:api.mycloud.com
      Invalid considered valid: http:/api.mycloud.com
      Valid considered invalid: http://api.mycloud.com
      Valid considered invalid http://api.appcloud21.dev.mozycloud.com/

      Can you review the logic used for validation? It may be just that it is missing a "!" somewhere.

        Activity

        Kaloyan Raev added a comment - - edited

        Hi, I'm currently blocked by this issue - I cannot create new Cloud Foundry server that connects to a custom CloudFoundry.org installation.

        Is there a workaround for this?

        When is it expected to have M3 released with the bugfix?

        Martin Lippert (c) added a comment -

        Hey Kaloyan!

        Unfortunately there is no workaround for this that I know, but we are working on getting out the fix for you asap. I will let you know once its available.

        -Martin

        Kaloyan Raev added a comment -

        Hi Martin,

        One possible workaround is to install M1. I checked with a colleague that has an older installation of STS/Cloud Foundry and this problem does not occur on M1. Unfortunately the update site provides only M2 and not older version. Perhaps, you could include M1 on the update site as a short term solution.

        Greetings,
        Kaloyan

        Martin Lippert (c) added a comment -

        Hey Kaloyan!

        You can install the nightly build of the CF plugin from this update site:
        http://dist.springsource.com/snapshot/TOOLS/nightly/cloudfoundry

        You might need to add additional update sites to your running Eclipse if you are not running STS.
        (a good composite choice is http://dist.springsource.com/milestone/TOOLS/update/e3.6/ for Eclipse 3.6 or http://dist.springsource.com/milestone/TOOLS/update/e3.7/ for Eclipse 3.7)

        As its a night build, there are some other changes in there (slightly changed deployment behavior), but if you have any problems with these builds, let us know.

        HTH,
        Martin

        Kaloyan Raev added a comment -

        Hi Martin,

        The issue is solved in the nightly build.
        Thank you for the quick support!

        Greetings,
        Kaloyan


          People

          • Assignee:
            Terry Hon (c)
            Reporter:
            Martin Lippert (c)
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: