Spring Tool Suite
  1. Spring Tool Suite
  2. STS-1780

NullPointerException when attempting to execute 'Update Maven Configuration'

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.6.1.RELEASE
    • Fix Version/s: 2.8.0.M2
    • Component/s: MAVEN
    • Labels:
    • Environment:

      Ubuntu 10.10 AND64 Desktop
      Sun JDK 1.6.0_24 64 bit
      Maven 2.2.1 (r801777; 2009-08-06 20:16:01+0100)

      Description

      Certain Maven projects give the following error when I try to execute 'Update Maven Configuration':

      An internal error occurred during: "Updating Maven Configuration".
      java.lang.NullPointerException

      The message returned is not very helpful in terms of where I should look to address the problem hence I'm a bit stumped on this one. Does STS write to a log anywhere? I'd be happy to provide more specific information if I can identify where the log is written to?

      Cheers,

      Edd

        Activity

        Martin Lippert (c) added a comment -

        Hey Edd!

        Please open the "Error Log" view. There you should find an entry that refers to this error. Would be great to get some stack trace from it. Thanks!!!

        Cheers,
        -Martin

        Edd Grant added a comment -

        Hi Martin,

        Stack trace attached:

        java.lang.NullPointerException
        at org.eclipse.wst.common.componentcore.internal.resources.VirtualComponent.create(VirtualComponent.java:364)
        at org.maven.ide.eclipse.wtp.WebProjectConfiguratorDelegate.configure(WebProjectConfiguratorDelegate.java:93)
        at org.maven.ide.eclipse.wtp.AbstractProjectConfiguratorDelegate.configureProject(AbstractProjectConfiguratorDelegate.java:75)
        at org.maven.ide.eclipse.wtp.WTPProjectConfigurator.configure(WTPProjectConfigurator.java:44)
        at org.maven.ide.eclipse.project.configurator.AbstractLifecycleMapping.configure(AbstractLifecycleMapping.java:57)
        at org.maven.ide.eclipse.internal.project.GenericLifecycleMapping.configure(GenericLifecycleMapping.java:48)
        at org.maven.ide.eclipse.internal.project.ProjectConfigurationManager.updateProjectConfiguration(ProjectConfigurationManager.java:306)
        at org.maven.ide.eclipse.internal.project.ProjectConfigurationManager.updateProjectConfiguration(ProjectConfigurationManager.java:292)
        at org.maven.ide.eclipse.actions.UpdateSourcesAction$1.runInWorkspace(UpdateSourcesAction.java:92)
        at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

        Session Data as follows:
        eclipse.buildId=2.6.1.201105041000-RELEASE
        java.version=1.6.0_24
        java.vendor=Sun Microsystems Inc.
        BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_GB
        Framework arguments: -product com.springsource.sts.ide
        Command-line arguments: -os linux -ws gtk -arch x86_64 -product com.springsource.sts.ide

        Martin Lippert (c) added a comment -

        Thanks, Edd, for the additional info. We will take a look.

        Sebastien Tardif added a comment -

        I have the same problem under Windows XP 32 bit using same IDE version.

        When this happen, I may see that the POM, which use package WAR, is recognized as a Java project. However, running on server do not show up. I then need to right click on project and do Maven -> Update project configuration, to get this fixed.

        !ENTRY org.eclipse.core.jobs 4 2 2011-06-22 15:56:13.721
        !MESSAGE An internal error occurred during: "Importing Maven projects".
        !STACK 0
        java.lang.NullPointerException
        at org.eclipse.wst.common.componentcore.internal.resources.VirtualComponent.create(VirtualComponent.java:364)
        at org.maven.ide.eclipse.wtp.WebProjectConfiguratorDelegate.configure(WebProjectConfiguratorDelegate.java:93)
        at org.maven.ide.eclipse.wtp.AbstractProjectConfiguratorDelegate.configureProject(AbstractProjectConfiguratorDelegate.java:75)
        at org.maven.ide.eclipse.wtp.WTPProjectConfigurator.configure(WTPProjectConfigurator.java:44)
        at org.maven.ide.eclipse.project.configurator.AbstractLifecycleMapping.configure(AbstractLifecycleMapping.java:57)
        at org.maven.ide.eclipse.internal.project.GenericLifecycleMapping.configure(GenericLifecycleMapping.java:48)
        at org.maven.ide.eclipse.internal.project.ProjectConfigurationManager.updateProjectConfiguration(ProjectConfigurationManager.java:306)
        at org.maven.ide.eclipse.internal.project.ProjectConfigurationManager.configureNewMavenProject(ProjectConfigurationManager.java:240)
        at org.maven.ide.eclipse.internal.project.ProjectConfigurationManager.importProjects(ProjectConfigurationManager.java:146)
        at org.maven.ide.eclipse.wizards.MavenImportWizard$1.runInWorkspace(MavenImportWizard.java:94)
        at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

        Sebastien Tardif added a comment -

        Complete project showing the many bugs of Spring IDE.

        Francis N added a comment -

        Here's another NullPointerException on "Updating Maven Configuration", different trace:

        eclipse.buildId=2.6.1.201105041000-RELEASE
        java.version=1.6.0_25
        java.vendor=Sun Microsystems Inc.
        BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_NZ
        Framework arguments: -product com.springsource.sts.ide
        Command-line arguments: -os win32 -ws win32 -arch x86 -product com.springsource.sts.ide

        Error
        Mon Jul 04 21:47:54 NZST 2011
        An internal error occurred during: "Updating Maven Configuration".

        java.lang.NullPointerException
        at org.maven.ide.eclipse.wtp.AbstractProjectConfiguratorDelegate.configureDeployedName(AbstractProjectConfiguratorDelegate.java:226)
        at org.maven.ide.eclipse.wtp.EarProjectConfiguratorDelegate.setModuleDependencies(EarProjectConfiguratorDelegate.java:128)
        at org.maven.ide.eclipse.wtp.WTPProjectConfigurator.mavenProjectChanged(WTPProjectConfigurator.java:63)
        at org.maven.ide.eclipse.internal.project.ProjectConfigurationManager.mavenProjectChanged(ProjectConfigurationManager.java:646)
        at org.maven.ide.eclipse.internal.project.registry.ProjectRegistryManager.notifyProjectChangeListeners(ProjectRegistryManager.java:636)
        at org.maven.ide.eclipse.internal.project.registry.ProjectRegistryManager.applyMutableProjectRegistry(ProjectRegistryManager.java:767)
        at org.maven.ide.eclipse.internal.project.registry.ProjectRegistryManager.refresh(ProjectRegistryManager.java:346)
        at org.maven.ide.eclipse.project.MavenProjectManager.refresh(MavenProjectManager.java:65)
        at org.maven.ide.eclipse.internal.project.ProjectConfigurationManager.updateProjectConfiguration(ProjectConfigurationManager.java:288)
        at org.maven.ide.eclipse.actions.UpdateSourcesAction$1.runInWorkspace(UpdateSourcesAction.java:92)
        at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

        Martin Lippert (c) added a comment -

        Since 2.8.0.M2 we have updated the m2e version and also the WTP integration for it. Do you still see this issue with that version?

        Edd Grant added a comment -

        Hi Martin, Nope - the issue doesn't seem to be occurring in 2.8.0.M2, although to be honest I think it may have stopped happening in 2.8.0.M1, but either way it's certainly not happening any longer.

        Martin Lippert (c) added a comment -

        Great, thanks for the feedback. Closing this.


          People

          • Assignee:
            Unassigned
            Reporter:
            Edd Grant
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: