Spring Tool Suite
  1. Spring Tool Suite
  2. STS-1480

"The filename or extension is too long" Error When DataNucleus Enhancer is Run Within STS

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.5.2.RELEASE
    • Fix Version/s: 2.6.0.RC1
    • Component/s: INTEGRATION
    • Environment:

      64-bit STS 2.5.2
      Java 1.6.0_22
      64-bit Windows 7 Operating System
      HW: Intel Core i5 M460

      Description

      The project has been generated using a roo script with the following database settings:

      persistence setup --provider DATANUCLEUS --database GOOGLE_APP_ENGINE --applicationId myprojectxyz001

      ..and the following post-domain object declaration options:

      gwt setup
      logging setup --level INFO

      After the project files are generated 'mvn gwt:run' is run from the command line successfully with the following warnings:

      [WARNING] advice defined in org.springframework.mock.staticmock.AnnotationDrivenStaticEntityMockingControl has not been applied [Xlint:adviceDidNotMatch]
      [WARNING] advice defined in org.springframework.mock.staticmock.AbstractMethodMockingControl has not been applied [Xlint:adviceDidNotMatch]
      [WARNING] advice defined in org.springframework.scheduling.aspectj.AbstractAsyncExecutionAspect has not been applied [Xlint:adviceDidNotMatch]

      ..and the following errors:

      [ERROR] 2011-01-14 16:59:35.333:INFO::Logging to STDERR via org.mortbay.log.StdErrLog
      [ERROR] 2011-01-14 16:59:35.632:INFO::jetty-6.1.x
      ...
      [ERROR] 2011-01-14 16:59:45.739:INFO::Started SelectChannelConnector@0.0.0.0:8888

      DataNucleus Enhancer seems to do its job when run in command line via mvn:

      ENHANCED (PersistenceCapable) : com.myproject.server.domain.DomainObject1
      ENHANCED (PersistenceCapable) : com.myproject.server.domain.DomainObject2
      ENHANCED (PersistenceCapable) : com.myproject.server.domain.DomainObject3
      ENHANCED (PersistenceCapable) : com.myproject.server.domain.DomainObject4
      ENHANCED (PersistenceCapable) : com.myproject.server.domain.DomainObject5
      ENHANCED (PersistenceCapable) : com.myproject.server.domain.DomainObject6

      When the generated project is loaded into STS, the following error is logged:

      DataNucleus Enhancer Error
      Cannot run program "C:\CLP\glassfishv3\jdk\bin\javaw.exe" (in directory "C:\CLP\spring\spring-roo-1.1.1.RELEASE\project\MyProjectXYZ001"): CreateProcess error=206, The filename or extension is too long

        Activity

        Cengiz Öner added a comment -

        This error occurs when the DataNucleus plugin is not installed. Installing the plugin resolves the issue.

        Please close this issue.

        NOTE: Google needs to update its documentation @ http://code.google.com/webtoolkit/doc/latest/tutorial/roo-sts.html since it only mentions installing the GPE plugin and not the DataNucleus one.

        Leo Dos Santos (c) added a comment -

        Yes, this appears to be a bug in Google App Engine and how it passes the list of .class files to be enhanced by DataNucleus. (see this thread http://groups.google.com/group/google-appengine-java/browse_thread/thread/0631eb8b4e6acc5e). I don't think there's anything to be done here on the STS side.

        Cengiz Öner added a comment -

        The particular problem mentioned in this issue occurs if the DataNucleus plugin is not installed and produces an error code 206 and a description of "The filename or extension is too long."

        The one that you mentioned is a separate problem which occurs when the list of classes to be subjected to ORM is invalid. This produces a similar error message, but with an error code of 87 and a description of "the parameter is incorrect." The solution for this is to change the GAE ORM settings from project properties to include only entity classes.

        Leo Dos Santos (c) added a comment -

        The thread that I linked too also references error 206, but maybe I didn't understand the cause very well. Is STS is not handling some setting properly that we should look at fixing, or is the dependency on the DataNucleus plugin satisfactory?

        Cengiz Öner added a comment -

        There is some confusion out there, because we have two error dialogs that display almost the same message.

        All things set aside, the problem described in this entry is not a bug. It is a result of not installing the DataNucleus plugin. There is nothing to fix in this issue, except for maybe displaying a useful error message.


          People

          • Assignee:
            Leo Dos Santos (c)
            Reporter:
            Cengiz Öner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: