Spring Tool Suite
  1. Spring Tool Suite
  2. STS-1363

tc Server developer edition bundled with STS 2.5.1 is missing the insight and base template making it impossible to create new instances

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Complete
    • Affects Version/s: 2.5.1.RELEASE
    • Fix Version/s: 2.5.2.RELEASE
    • Component/s: None
    • Labels:
      None
    • Environment:

      springsource-tool-suite-2.5.1.RELEASE-e3.6.1-macosx-cocoa-x86_64.tar.gz

      Description

      I've seen this on Mac, and it's been reported on Mac by a user. I don't know if it applies to other platforms.

      Templates bundled with STS:

      [wilkinsona-desktop]: ls -al /Users/wilkinsona/Downloads/springsource/tc-server-developer-2.1.0.RELEASE/templates/
      total 0
      drwxr-xr-x@ 12 wilkinsona  staff  408 11 Nov 18:04 .
      drwxr-xr-x@ 14 wilkinsona  staff  476 23 Nov 14:03 ..
      drwxr-xr-x@  5 wilkinsona  staff  170 11 Nov 18:04 ajp
      drwxr-xr-x@  5 wilkinsona  staff  170 11 Nov 18:04 apr
      drwxr-xr-x@  5 wilkinsona  staff  170 11 Nov 18:04 apr-ssl
      drwxr-xr-x@  5 wilkinsona  staff  170 11 Nov 18:04 bio
      drwxr-xr-x@  5 wilkinsona  staff  170 11 Nov 18:04 bio-ssl
      drwxr-xr-x@  5 wilkinsona  staff  170 11 Nov 18:04 cluster-node
      drwxr-xr-x@  4 wilkinsona  staff  136 11 Nov 18:04 diagnostics
      drwxr-xr-x@  4 wilkinsona  staff  136 11 Nov 18:04 jmx-ssl
      drwxr-xr-x@  5 wilkinsona  staff  170 11 Nov 18:04 nio
      drwxr-xr-x@  5 wilkinsona  staff  170 11 Nov 18:04 nio-ssl
      

      Templates in the tc Server zip:

      [wilkinsona-desktop]: ls -al /Users/wilkinsona/Downloads/springsource-tc-server-developer/templates/
      total 0
      drwxr-xr-x  14 wilkinsona  staff  476  4 Nov 12:59 .
      drwxr-xr-x  12 wilkinsona  staff  408  4 Nov 12:58 ..
      drwxr-xr-x   5 wilkinsona  staff  170  4 Nov 12:58 ajp
      drwxr-xr-x   5 wilkinsona  staff  170  4 Nov 12:58 apr
      drwxr-xr-x   5 wilkinsona  staff  170  4 Nov 12:49 apr-ssl
      drwxr-xr-x  10 wilkinsona  staff  340  4 Nov 12:50 base
      drwxr-xr-x   5 wilkinsona  staff  170  4 Nov 12:58 bio
      drwxr-xr-x   5 wilkinsona  staff  170  4 Nov 12:58 bio-ssl
      drwxr-xr-x   5 wilkinsona  staff  170  4 Nov 12:58 cluster-node
      drwxr-xr-x   4 wilkinsona  staff  136  4 Nov 12:58 diagnostics
      drwxr-xr-x   9 wilkinsona  staff  306  4 Nov 12:59 insight
      drwxr-xr-x   4 wilkinsona  staff  136  4 Nov 12:58 jmx-ssl
      drwxr-xr-x   5 wilkinsona  staff  170  4 Nov 12:49 nio
      drwxr-xr-x   5 wilkinsona  staff  170  4 Nov 12:58 nio-ssl
      

        Activity

        Christian Dupuis added a comment - - edited

        Sorry, we are not going to ship the insight stuff twice. This is simply too big.

        I can add the base template back although is attached with some download size.

        Christian

        Christian Dupuis added a comment -

        Decreasing the priority as this is not affecting any core STS functionality.

        Christian

        Christian Dupuis added a comment -

        Added back both templates and implemented auto instance creation during workspace configuration. That will prevent shipping insight twice.

        Christian

        Prince Richard added a comment -

        This issue is occurring in the STS download for Linux. I am unable to create new instances and getting the same error due to missing base directory under templates.

        Prince Richard added a comment -

        STS download details -
        springsource-tool-suite-2.5.1.RELEASE-e3.6.1-linux-gtk-installer.sh

        Martin Lippert (c) added a comment -

        The issue is independent of the platform STS is running on or build for. So the fix that Christian committed for the upcoming 2.5.2 release should work for the Linux build as well.


          People

          • Assignee:
            Unassigned
            Reporter:
            Andy Wilkinson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: