Spring Tool Suite
  1. Spring Tool Suite
  2. STS-1231

STS install failure in Galileo due to version issue with Mylyn 3.4

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.3.2.RELEASE
    • Fix Version/s: 2.5.0.RC1
    • Component/s: None
    • Labels:
    • Environment:

      Windows 7, ECLIPSE 3.5.2

      Description

      STS will not install due to dependency on org.eclipse.mylyn_feature.feature.group. This looks a lot like #STS-831. However, this case appears to indicate that Mylyn 3.4 cannot be used with the 2.3.2.201003230009-RELEASE version. We're constrained to Mylyn 3.4+ due to other plugins needing 3.4 so cannot rollback to 3.3.x.

      Currently installed: org.eclipse.mylyn_feature.feature.group(3.4.1.v20100804-0100-e3x-7Z7f5FBBoPbPQ_XlFeZXJ8)
      Attempted to use STS update sites: http://springide.org/updatesite; http://www.springsource.com/update/e3.5

      Other enabled updates sites:
      http://download.eclipse.org/eclipse/updates/3.5
      http://download.eclipse.org/releases/galileo
      http://download.eclipse.org/technology/epp/packages/galileo
      http://download.eclipse.org/technology/swtbot/galileo/dev-build/update-site
      http://download.eclipse.org/tools/ajdt/35/update
      http://download.eclipse.org/tools/mylyn/update/e3.4/
      http://download.eclipse.org/tools/mylyn/update/extras (not accessible)
      http://download.eclipse.org/webtools/updates
      http://download.jboss.org/jbosstools/updates/stable/
      http://subclipse.tigris.org/update_1.6.x
      http://update.atlassian.com/atlassian-eclipse-plugin/e3.5/
      http://www.springsource.com/update/e3.5

      Additional notes:

      No repository found at http://download.eclipse.org/tools/mylyn/update/extras.

      Galileo error during install:

      Cannot complete the install because one or more required items could not be found.
      Software being installed: SpringSource Tool Suite (required) 2.3.2.201003230009-RELEASE (com.springsource.sts.feature.group 2.3.2.201003230009-RELEASE)
      Missing requirement: SpringSource Tool Suite (required) 2.3.2.201003230009-RELEASE (com.springsource.sts.feature.group 2.3.2.201003230009-RELEASE) requires 'org.eclipse.mylyn_feature.feature.group [3.3.2.I20100208,3.4.0)' but it could not be found

        Activity

        Hide
        Steffen Pingel added a comment -

        Hi Randall,

        if you require Mylyn 3.4 you would need to use STS 2.5M3 which is available from the snapshot repositories:

        http://dist.springsource.com/milestone/TOOLS/update/e3.5
        http://dist.springsource.com/milestone/TOOLS/composite/e3.5

        STS 2.3.2 is unfortunately not compatible with Mylyn 3.4.

        Hope that helps.

        Steffen

        Show
        Steffen Pingel added a comment - Hi Randall, if you require Mylyn 3.4 you would need to use STS 2.5M3 which is available from the snapshot repositories: http://dist.springsource.com/milestone/TOOLS/update/e3.5 http://dist.springsource.com/milestone/TOOLS/composite/e3.5 STS 2.3.2 is unfortunately not compatible with Mylyn 3.4. Hope that helps. Steffen
        Hide
        Randall S. Becker added a comment -

        Thank you Steffen. Using STS 2.5 resolves the block. I've verified on the above configuration and that the plug-in is functional.

        Show
        Randall S. Becker added a comment - Thank you Steffen. Using STS 2.5 resolves the block. I've verified on the above configuration and that the plug-in is functional.
        Hide
        Steffen Pingel added a comment -

        Great that you were able to resolve it. I'll mark this issue as fixed.

        Show
        Steffen Pingel added a comment - Great that you were able to resolve it. I'll mark this issue as fixed.

          People

          • Assignee:
            Unassigned
            Reporter:
            Randall S. Becker
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: