Enterprise Bundle Repository
  1. Enterprise Bundle Repository
  2. EBR-622

Parts of the AspectJ Weaver 1.6.8.RELEASE bundle are compiled with java 1.6, preventing its use in 1.5 deployments.

    Details

    • Type: Defect Defect
    • Status: To Do To Do
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Labels:
      None

      Description

      The testData package in the AspectJ Weaver 1.6.8.RELEASE bundle is compiled with Java 1.6

      It causes the following exception when deploying a web app that contains that bundle on a Jboss 5.1.0 GA running on Java 1.5

      10:33:52,603 WARN [ClassLoaderManager] Unexpected error during load of:testdata.SomeAnnotation
      java.lang.UnsupportedClassVersionError: Bad version number in .class file
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:675)
      at org.jboss.classloader.spi.base.BaseClassLoader.access$200(BaseClassLoader.java:63)

        Activity

        Hide
        Marc Kropholler added a comment -

        moving the all dependencies (except the project artifacts) to /default/lib fixed the issue for us.

        Show
        Marc Kropholler added a comment - moving the all dependencies (except the project artifacts) to /default/lib fixed the issue for us.
        Hide
        Robert Klaus added a comment -

        We were running in the same problem by using Spring. The 1.6.11 (current release) also has this problem.

        Filed a bug for the aspectj guys: https://bugs.eclipse.org/bugs/show_bug.cgi?id=341446

        Show
        Robert Klaus added a comment - We were running in the same problem by using Spring. The 1.6.11 (current release) also has this problem. Filed a bug for the aspectj guys: https://bugs.eclipse.org/bugs/show_bug.cgi?id=341446
        Hide
        Andy Clement (c) added a comment -

        I've just commented on the AspectJ bug that Robert raised. Shame I wasn't aware of this EBR issue or I could have fixed it sooner. It will be fixed in 1.6.12 I'm just debating whether to rebuild 1.6.11 to include the change (is 1.6.11 in EBR yet?)

        Show
        Andy Clement (c) added a comment - I've just commented on the AspectJ bug that Robert raised. Shame I wasn't aware of this EBR issue or I could have fixed it sooner. It will be fixed in 1.6.12 I'm just debating whether to rebuild 1.6.11 to include the change (is 1.6.11 in EBR yet?)
        Hide
        Glyn Normington (c) added a comment -

        From the updated FAQ:

        What is the current status of the repository?

        The repository is frozen but will remain accessible until at least 1 September 2014. See http://www.eclipse.org/ebr/ for information regarding the Eclipse Bundle Recipes project to which users of the SpringSource Enterprise Bundle Repository should transition.

        Show
        Glyn Normington (c) added a comment - From the updated FAQ: What is the current status of the repository? The repository is frozen but will remain accessible until at least 1 September 2014. See http://www.eclipse.org/ebr/ for information regarding the Eclipse Bundle Recipes project to which users of the SpringSource Enterprise Bundle Repository should transition.

          People

          • Assignee:
            Unassigned
            Reporter:
            Michael Visee
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              First Response Date: