Details

    • Type: Defect Defect
    • Status: Done Done
    • Priority: Minor Minor
    • Resolution: Complete
    • Labels:
      None

      Description

      The manifest files for the tiles core & servlet packages should include a spring range including 3.x. (this is particularly useful when building roo based modules view modules)

      see attached manifests for the modifications. (spring ranges might need changing to be scoped a little wider)

        Activity

        Hide
        Joris Kuipers added a comment -

        I would suggest to use an even wider upper version range boundary than 3.0.1: I suspect that the whole Spring 3.x series will be compatible, so 4.0.0 might be more appropriate. BTW, it would be interesting to see which other EBR bundles have (possible optional) dependencies on Spring to see if their version range needs to be expanded as well.

        Show
        Joris Kuipers added a comment - I would suggest to use an even wider upper version range boundary than 3.0.1: I suspect that the whole Spring 3.x series will be compatible, so 4.0.0 might be more appropriate. BTW, it would be interesting to see which other EBR bundles have (possible optional) dependencies on Spring to see if their version range needs to be expanded as well.
        Hide
        Chris Frost added a comment -

        This has now been raised by a user on the forums. http://forum.springsource.org/showthread.php?t=83407

        Tiles 2.1.4 is also now out so that version should be added to the EBR with the expanded version ranges, as Joris says, something up to ',4.0.0)' might be a nice idea.

        Show
        Chris Frost added a comment - This has now been raised by a user on the forums. http://forum.springsource.org/showthread.php?t=83407 Tiles 2.1.4 is also now out so that version should be added to the EBR with the expanded version ranges, as Joris says, something up to ',4.0.0)' might be a nice idea.
        Hide
        John McLaughlin added a comment -

        Is there any progress on getting version added 2.1.4 to EBR with a useful version range?

        Show
        John McLaughlin added a comment - Is there any progress on getting version added 2.1.4 to EBR with a useful version range?
        Hide
        Chris Frost added a comment - - edited

        Unfortunately not, I'd quite like to see it go in as well. I'm not sure who I can poke in the company to do it, no one is directly assigned to the EBR these days. I'll ask some questions

        Show
        Chris Frost added a comment - - edited Unfortunately not, I'd quite like to see it go in as well. I'm not sure who I can poke in the company to do it, no one is directly assigned to the EBR these days. I'll ask some questions
        Hide
        Chris Frost added a comment -

        Hi,

        It seems there is actually spending some time on it so I have pointed them at this one and registered my vote for it as well so we will have to wait and see.
        Sorry it's not getting more attention but I have hope this will improve in the future.

        Thanks,
        Chris.

        Show
        Chris Frost added a comment - Hi, It seems there is actually spending some time on it so I have pointed them at this one and registered my vote for it as well so we will have to wait and see. Sorry it's not getting more attention but I have hope this will improve in the future. Thanks, Chris.
        Hide
        Brian Nelson added a comment -

        Scott suggested to add 2.1.4 instead of modifying 2.1.3.

        Show
        Brian Nelson added a comment - Scott suggested to add 2.1.4 instead of modifying 2.1.3.
        Hide
        Brian Nelson added a comment -

        This has been done.

        Show
        Brian Nelson added a comment - This has been done.

          People

          • Assignee:
            Brian Nelson
            Reporter:
            Benjamin Conlan
          • Votes:
            3 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: