dm Server
  1. dm Server
  2. DMS-2266

No application trace produced for a .war file

    Details

    • Type: Defect Defect
    • Status: Done Done
    • Priority: Minor Minor
    • Resolution: Works as Designed
    • Affects Version/s: 2.0.0.RC1
    • Fix Version/s: None
    • Component/s: None

      Description

      This can be reproduced on 2.0.0.RC1 by dropping the attached helloweb.war into pickup, invoking the /helloweb servlet using a browser, and then observing the contents of the servicability/logs directory. No directory with "helloweb" in the name appears.

      The admin console shows the war file as correctly deployed with type "bundle", name "helloweb", and version 0.0.0.

        Activity

        Glyn Normington (c) added a comment -

        This is not a bug as the attached application doesn't do any logging. We do not weave the Tomcat code that performs normal request processing, so no logging occurs for a .war file unless the application does some logging.

        For an example of application specific trace working for a .ware file, adding the following to config/serviceability.xml and then invoke the splash screen (with context path "/"):

        <logger level="TRACE" name="com.springsource.server.splash">
        </logger>

        The directory named "serviceability/logs/com.springsource.server.splash-2.0.0.RC1" containing log files is then created.


          People

          • Assignee:
            Unassigned
            Reporter:
            Glyn Normington (c)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: