dm Server
  1. dm Server
  2. DMS-2019

Properties resolution from a plan not working in CI-460 and newer

    Details

    • Type: Defect Defect
    • Status: Done Done
    • Priority: Minor Minor
    • Resolution: Works as Designed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None

      Description

      In the newest snapshot builds (>= CI-460) the resolution of properties referenced in a plan seems not to work anymore. The following simple plan fails

      <plan name="foo.bar.plan" version="1.2.0.SNAPSHOT" scoped="false" atomic="true"
          xmlns="http://www.springsource.org/schema/dm-server/plan"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://www.springsource.org/schema/dm-server/plan 
              http://www.springsource.org/schema/dm-server/plan/springsource-dm-server-plan.xsd">
          <artifact type="properties" name="foo.bar.ServiceA"/>
      </plan>
      

      with the message

      Caused by: com.springsource.kernel.deployer.core.DeploymentException: properties 'foo.bar.ServiceA' version '[0.0.0, ∞)' not found
      	at com.springsource.kernel.install.artifact.internal.StandardInstallArtifactTreeInclosure.createInstallTree(StandardInstallArtifactTreeInclosure.java:99)
      	at com.springsource.kernel.deployer.core.internal.PlanResolver.createInstallArtifactTree(PlanResolver.java:116)
      	... 23 common frames omitted
      

      even if there is a properties file named foo.bar.ServiceA.properties in repository/usr.

      -rw-r--r-- 1 christian christian 8 2009-11-09 09:23 foo.bar.ServiceA.properties
      

        Activity

        Andy Wilkinson added a comment -

        In the latest nightly builds we've changes the artifact type for configuration from "properties" to "configuration" to reflect the fact that properties file format is just one rendering of configuration and to allow us, in the future, to support different file formats for configuration. Apologies for any inconvenience this has caused, this information will be covered in the new and noteworthy for the next milestone / RC1.


          People

          • Assignee:
            Unassigned
            Reporter:
            Christian Brensing
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              First Response Date: